PDA

View Full Version : gui crashes after ati installation



agd_scorp
2013-04-29, 15:06
I have hp pavillion g6 within radeon hd 6470m and intel3000 graphics.
after I install proper ati non free drivers from amd.com and type
aticonfig --initial
it creates /etc/X11/xorg.conf file
after i reboot gui(Xserver) doesnt start and it returns to shell login.
when I type fglrxinfo it says "unable to open display (null)"
and gui doesnt start unless I remove /etc/X11/xorg.conf

also there were a lot of errors on installation (ie. dkms not build, version.h not found, libGL.so.1 not found ...) but i fixed them so there is no mistake on installation
I tried about 30 different ways to correct this but nothing changed (adding nomodeset, radeon.modeset=0 blah blah to grub, successfully installing fglrx-driver with apt-get(it gives blinking cursor with no gui tough), writing my custom Xorg.conf file, using X -configure output as Xorg.conf, downgrading Xserver to 1.11 instead 1.13)

I know there is always problem with hybrid graphics on linux(especially when u dont have some menu about gpus in your bios) but once i succeed to run my radeon card(also catalyst) after long processes on backtrack 5r3.

there isnt gpu mode(doesnt have any options about anything thanks to hp) on my bios menu.

my kali defaultly uses mesa driver but it heats pc like **** and I guess it uses integrated intel gpu
btw I use kali 1.0.2 amd64 with kernel 3.7-blah and fully upgraded(distro and repos)

here is Xorg.0.log
error lines emphasised



[ 17.605]
X.Org X Server 1.11.4
Release Date: 2012-01-27
[ 17.605] X Protocol Version 11, Revision 0
[ 17.605] Build Operating System: Linux 3.2.0-1-amd64 x86_64 Debian
[ 17.605] Current Operating System: Linux scorp 3.7-trunk-amd64 #1 SMP Debian 3.7.2-0+kali6 x86_64
[ 17.605] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7-trunk-amd64 root=UUID=82e9692e-347b-4e02-8716-802f27dab341 ro initrd=/install/gtk/initrd.gz quiet nomodeset
[ 17.605] Build Date: 04 March 2012 11:42:13PM
[ 17.605] xorg-server 2:1.11.4-1 (Cyril Brulebois <kibi@debian.org>)
[ 17.605] Current version of pixman: 0.26.0
[ 17.605] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 17.606] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 17.606] (==) Log file: "/var/log/Xorg.1.log", Time: Mon Apr 29 03:00:32 2013
[ 17.606] (==) Using config file: "/etc/X11/xorg.conf"
[ 17.606] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 17.606] (==) ServerLayout "aticonfig Layout"
[ 17.606] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[ 17.606] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
[ 17.607] (**) | |-->Device "aticonfig-Device[0]-0"
[ 17.607] (==) Automatically adding devices
[ 17.607] (==) Automatically enabling devices
[ 17.607] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[ 17.607] Entry deleted from font path.
[ 17.607] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 17.607] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 17.607] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 17.607] (II) Loader magic: 0x7f498b009ae0
[ 17.607] (II) Module ABI versions:
[ 17.607] X.Org ANSI C Emulation: 0.4
[ 17.607] X.Org Video Driver: 11.0
[ 17.607] X.Org XInput driver : 13.0
[ 17.607] X.Org Server Extension : 6.0
[ 17.608] (--) PCI:*(0:0:2:0) 8086:0046:103c:1669 rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00006050/8
[ 17.609] (--) PCI: (0:1:0:0) 1002:6760:103c:1669 rev 0, Mem @ 0xa0000000/268435456, 0xc6400000/131072, I/O @ 0x00005000/256, BIOS @ 0x????????/131072
[ 17.609] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 17.609] (II) "extmod" will be loaded by default.
[ 17.609] (II) "dbe" will be loaded by default.
[ 17.609] (II) "glx" will be loaded by default.
[ 17.609] (II) "record" will be loaded by default.
[ 17.609] (II) "dri" will be loaded by default.
[ 17.609] (II) "dri2" will be loaded by default.
[ 17.609] (II) LoadModule: "fglrx"
[ 17.609] (WW) Warning, couldn't open module fglrx
[ 17.609] (II) UnloadModule: "fglrx"
[ 17.609] (II) Unloading fglrx
[ 17.609] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 17.609] (II) LoadModule: "i915"
[ 17.610] (WW) Warning, couldn't open module i915
[ 17.610] (II) UnloadModule: "i915"
[ 17.610] (II) Unloading i915
[ 17.610] (EE) Failed to load module "i915" (module does not exist, 0)
[ 17.610] (II) LoadModule: "extmod"
[ 17.610] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 17.610] (II) Module extmod: vendor="X.Org Foundation"
[ 17.611] compiled for 1.11.4, module version = 1.0.0
[ 17.611] Module class: X.Org Server Extension
[ 17.611] ABI class: X.Org Server Extension, version 6.0
[ 17.611] (II) Loading extension SELinux
[ 17.611] (II) Loading extension MIT-SCREEN-SAVER
[ 17.611] (II) Loading extension XFree86-VidModeExtension
[ 17.611] (II) Loading extension XFree86-DGA
[ 17.611] (II) Loading extension DPMS
[ 17.611] (II) Loading extension XVideo
[ 17.611] (II) Loading extension XVideo-MotionCompensation
[ 17.611] (II) Loading extension X-Resource
[ 17.611] (II) LoadModule: "dbe"
[ 17.611] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 17.611] (II) Module dbe: vendor="X.Org Foundation"
[ 17.611] compiled for 1.11.4, module version = 1.0.0
[ 17.611] Module class: X.Org Server Extension
[ 17.611] ABI class: X.Org Server Extension, version 6.0
[ 17.611] (II) Loading extension DOUBLE-BUFFER
[ 17.611] (II) LoadModule: "glx"
[ 17.611] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 17.611] (II) Module glx: vendor="X.Org Foundation"
[ 17.611] compiled for 1.11.4, module version = 1.0.0
[ 17.612] ABI class: X.Org Server Extension, version 6.0
[ 17.612] (==) AIGLX enabled
[ 17.612] (II) Loading extension GLX
[ 17.612] (II) LoadModule: "record"
[ 17.612] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 17.612] (II) Module record: vendor="X.Org Foundation"
[ 17.612] compiled for 1.11.4, module version = 1.13.0
[ 17.612] Module class: X.Org Server Extension
[ 17.612] ABI class: X.Org Server Extension, version 6.0
[ 17.612] (II) Loading extension RECORD
[ 17.612] (II) LoadModule: "dri"
[ 17.612] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 17.613] (II) Module dri: vendor="X.Org Foundation"
[ 17.613] compiled for 1.11.4, module version = 1.0.0
[ 17.613] ABI class: X.Org Server Extension, version 6.0
[ 17.613] (II) Loading extension XFree86-DRI
[ 17.613] (II) LoadModule: "dri2"
[ 17.613] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 17.613] (II) Module dri2: vendor="X.Org Foundation"
[ 17.613] compiled for 1.11.4, module version = 1.2.0
[ 17.613] ABI class: X.Org Server Extension, version 6.0
[ 17.613] (II) Loading extension DRI2
[ 17.613] (II) LoadModule: "fglrx"
[ 17.614] (WW) Warning, couldn't open module fglrx
[ 17.614] (II) UnloadModule: "fglrx"
[ 17.614] (II) Unloading fglrx
[ 17.614] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 17.614] (EE) No drivers available.
[ 17.614]
Fatal server error:
[ 17.614] no screens found
[ 17.614]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 17.614] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 17.614]

charonsecurity
2013-04-30, 09:05
I also have switchable graphics. Check this tread, http://forums.kali.org/showthread.php?59-AMD-Catalyst-Mobility-Radeon-HD-4670-driver&highlight=switchable