View Full Version : Loading in multi-boot usb, login problem

2013-03-13, 20:17
Hi, I was able to boot Backtrack on a multi-boot usb-stick by decompressing the iso to a folder (%USB-STICK%/ISO/BT5) and by using grub4dos with this menu :
title BackTrack\nPentesting Linux Distribution
kernel /ISO/BT5/casper/vmlinuz --ignore-floppies file=/cdrom/preseed/custom.seed live-media-path=ISO/BT5/casper boot=casper locale=en_GB.UTF-8 keyb=us splash noprompt vga=791-- persistent
initrd /ISO/BT5/casper/initrd.gz

I tried the same with kali by changing the kernel , initrd, and live-media-path to fit and i can boot fine up to the login screen.

there it asks for the username/password, i input "root" then "toor" and it says "Authentication failed"

Do anyone have an idea what's wrong?

2013-03-14, 01:34
Is toor the password you setup for your account? I had the same problem but I signed in by using root and the password I setup for the name/password for my account.

2013-03-14, 02:02
I might have solved this for you, I had a very similar problem. When prompted to enter your username, enter root. Then when prompted for a password, try the password you were asked for during installation. After doing this I suggest creating another user account with your own username and password.

2013-03-14, 03:57
Hi Deux-Ex
debian based distros use live-boot system, specifically made for debian.
forget about ubuntu's casper system.
Once you have understood the basics of debian-live system, then you will be able to make a live USB easily again, like you did in BT.
You are wellcome to join debian-live mailing lists to get standard debian-live support, which will be also very useful to kali users, indeed.

2013-03-14, 13:27
thank you all for the comments ;)
first off, mhansen and sampramer, i did not install kali, i'm trying to boot it live like from the cd but on a multi-boot usb controled with a grub4dos menu (presently i have liveOS's = Ubuntu 32/64, backtrack, bugtraq, backbox, gparted, paragon, acronis, dban, win7(not live but for install), win server 2008r2(for install))
Your suggestion is great but sadly not applicable to my problem since i use the original live system and not an install...... thank you for trying though ;)

alist3r, i'm not using the casper system. I should have included the menu i edited for booting kali directly from usb to prevent misunderstanding so here it is:

title Kali-Linux\nPentesting Linux Distribution
kernel /ISO/Kali-Linux/live/vmlinuz --ignore-floppies live-media-path=ISO/Kali-Linux/live boot=live locale=en_GB.UTF-8 keyb=us splash noprompt vga=791--
initrd /ISO/Kali-Linux/live/initrd.img

Essentially, all i did was put all the files contained in the ISO of Kali into the folder ISO/Kali-Linux on my usb-key with grub4dos and it boot normaly, i get to the login screen without problem but it doesnt accept the default login credentials.......

2013-03-14, 21:35
live-boot is the agent responsible for setting the user credentials in boot time. That is, base system does not contain the user until it boots, so a wrong boot or a wrong live-boot script executio could lead to similar issues.
I should make more tests. I can not notice problems in boot params, but maybe one parameter is missing so live-boot fails doing its job.
Meanwhile, you can compare kernel bootparams used in kali's original ISO, maybe you will find the problem for yourlself before I could get in front of a PC with a copy of Kali (Im not able to test at tis time)


2013-03-15, 17:12
You.....are....a genious!!!!!!!!
never thought of it.
whent to look in the iso and found the missing parameters :noconfig=sudo username=root hostname=kali
added them in my menu and VOILA
everything working.

so for those who want to know the complete menu for the boot there it is
*******extract ISO to a folder on usbkey that have grub4dos installed ( ie:/ISO/Kali-Linux)******
title Kali-Linux\nPentesting Linux Distribution
kernel /ISO/Kali-Linux/live/vmlinuz --ignore-floppies live-media-path=ISO/Kali-Linux/live boot=live noconfig=sudo username=root hostname=kali locale=en_GB.UTF-8 keyb=us splash noprompt vga=791--
initrd /ISO/Kali-Linux/live/initrd.img

2013-11-26, 19:11
i had same problem, during installation i wrote toor as password, and was unable to login at first.

then i rebooted and from grub opened recovery. when you open it you get prompt, logged as root.

than just type:


after that chose and type your password, retype and write:


you will continue to normal system boot and login.

login as root and just choosen password.

hope this helps.

2016-03-22, 10:30
Hi @ Deus-Ex

I've registered to the site looking for help about the Kali Live Usb question. I've modified my menu.lst (with the right paths) & everything goes fine, everything seems to load, but at the end i get a black screen with the mouse's cursor operative, & nothing else happens.

If i've well understood you, that i have to put into the pendrive is the content of the kali.iso, & not the .iso itself, i'm right?

Some that i have to say is that i'm tryin' it with the last Kali version (kali-linux-2016.1-i386.iso), and the pendrive is a 32gb one, ntfs formated, with a lot of stuff that runs as a charm.

May be ntfs responsible of the fail? I've Trinity runing fine in the same pendrive, but for make it run in ntfs i had to make a Fat16 image of it first.

Thx a lot in advance.

2016-03-23, 07:13
Well, i've fixed it.

I've been failing 'cause i was working witha 64Bits version of Kali! :)

So now i'm booting succesfully from the stick to install ntldr systems, bootmgr systems, linux, debian, ubuntu, run live d.o.s., live linux, live "wins", etc...

Trillon thx to @exDeus & @alist3r!!!!

Btw; i'll share all that i've made, if it means something useful for someone.


Edit; i'm so sorry, i was wrong, i did'nt fixed nothing, my mistake. Is true that the 32bits version of Kali, "kali-linux-light-2016.1-i386.iso", works flawlessly once extracted the files onto a folder in the pendrive & the paths of the menu.lst are right. Is a nice tool, but i still can't get to boot the complete version, "kali-linux-2016.1-i386.iso". To add a detail, before the screen goes black, with the mouse's cursor & the keyboard active, the last verbose mention displayed in the screen is "Start user manager for UID0".

I would like to know what i'm doin' wrong, or if the issue is caused by the big size of the kali folder. Is strange, i can't figure out why the light version runs & the complete wont.

Thx a lot in advance, & excuse me for my rush & wrong conclussions.