View Full Version : Mounting ARM img Issue

2013-03-21, 19:22
UPDATE: I got around the mount issue by using macfuse and then copying into a disk image through vmware.

I wasn't sure whether to throw this into the arm section or desktop section as it deals with both.

I'm trying to mount the ss808 image in the desktop VM of Kali to work on a resize, and no matter what FS type I use I get something along the lines of:

Wrong FS type, bad option, bad superblock on dev/loop1 and if I check dmesg, I get

error: can't find ext(x) filesystem on dev loopx

Commands I've tried:

mount -o loop /img /mnt

mount -o loop -t extx /img /mnt

losetup /dev/loop0 /img
mount -o loop -t ext4 /dev/loop /mnt

I've tried mounting as ext2, 3 and 4. Same error.

Any help would be awesome! Thanks!

2013-04-16, 20:42
since its an img not an iso you have to set its offest, in this case 512. so you would mount it like "$sudo mount -o loop,offset=512 /path/to/kali.img /path/to/mountpoint"

to determine the offset you need to multiply the block size by its start, fdisk -l the kali.img and you will find 512 and 1. hence 512 is your offset.