View Full Version : mini iso - unmet dependencies

2013-05-03, 09:22
Im trying to install kali using 1.0.1 mini iso for amd64.
After selected "Select and Install Software", and "Software selection" when I check "Kali's penetration testing tools" and so on, then I press enter to continue, then after a few seconds of instalation process stops with message "Installation step failed". On console #4 I can see info about unmet dependencies for kali-linux wich depends on openvas, wich cannot be installed.
Please help :)

2013-05-04, 09:56
same problem here, apt-get dist-upgrade removed kali-linux package, cannot reinstall now cause of unmet dependencies with openvas

2013-05-05, 19:09
The same problem with me too so it happened when I ran "apt-get dist-upgrade" and after that I also ran "apt-get auto-remove" it removed the openvas package.

Anyone know how to install the openvas again on Kali Linux?

2013-05-13, 16:47
Actually, the mini ISO 1.0.1 seems to have an issue with Libopenvas concurrent versions.
I’m not quite sure about what I discover and understood, so I prefer to explain all in order to let everyone to answer and explain me more.

I downloaded the kali-linux-1.0.1-i386-mini.iso from the official Kali site (http://www.kali.org/downloads/) and burn on a CD-Rom.
After inserting this CD and booting, I follow almost the instructions of Kali (”http://docs.kali.org/network-install/kali-linux-network-mini-iso-install”) Linux Network Mini ISO Install[/URL].

Into the panel “Software Selection”, I chose some options. I cannot remember exactly but it should be : Kali stuff, SSH server, Laptop, Standard system Utilities.
Then it took a while (more than 2 hours) to get all the packages (by downloading) and try to install them. In fact I had questions for Kismet and inetd, after that by the end of the progress bar, the installation crashed notifying me with a red panel.

By the way, may I suggest the Kali team to separate in different steps this “huge part of the software installation” (2 hours of downloads). In order to help the investigations and the re-installation, I would recommend to separate the installation of the Printer, web server, file server, SSH, and so on.

Anyway, back to the installation main menu, I chose to install Grub, and I selected the “finish the installation” (Sorry guys, I can’t remember the exact name). After a boot, I could log me in the new installation (in fact the Debian system) with the root account and the password set before in the previous installation.

In the directory /var/log/installer I found out some clues, especially in the syslog file but I’m not an expert.
As I understood the main package named kali-linux includes more than 1500 packages. I checked the Packages file where I think the repository is: http://http.kali.org/kali/dists/kali/main/binary-i386/
I let you see it for more details but actually this meta-package contains a lot of “kali stuff” package.

So I try to “aptitude install kali-linux” and the result is a conflict between libopenvas5 and libopenvas6. As a workaround, I chose the solution “do not install libopenvas6”. This choice is due to the package description and because I prefer to eventually upgrade this lib later.
Package: libopenvas6
Conflicts: libopenvas1, libopenvas2, libopenvas3, libopenvas4, libopenvas5, libopenvasnasl1, libopenvasnasl2
Replaces: libopenvas1, libopenvas2, libopenvas3, libopenvas4, libopenvas5, libopenvasnasl1, libopenvasnasl2

That’s a first step to avoid this error of the kali-linux-1.0.1-i386-mini.iso installation menu, but the result is not as it should be (lack of gnome, and so on).
I search the web and in the documentation of the kali.org but without success. Maybe someone can indicate me the list of packages I had to install in order to install all I need.

[Edit 14/05/2013] In order to help each other, I added that I found in the Kali bug tracker a similar dependency issue n° 340 (http://bugs.kali.org/view.php?id=340).
After reflexion, I installed again differently. In fact, I followed the instructions of Kali (”http://docs.kali.org/network-install/kali-linux-network-mini-iso-install”) Linux Network Mini ISO Install[/URL], but without chose the "Kali's penetration testing tool" option. I know that's a bit weird for a kali installation, but my goal was to prove that this is this option which generates the issue. Bingo ! The installation finished without issue (and in fact I write this edit from the kali iceweasel ) with the options below:
_ Debian desktop environnement
_ SSH server
_ Laptop
_ Standard system utilities

So now, in order to improve my installation (and get a real Kali pen' testing), I have to use aptitude. Currently I need to know which packages are concerned by the "Kali's penetration testing tool" option. How can I determinated that? Is Kali-Linux is the only one?

2013-05-15, 00:45
Thanks for your report oloc, I was stuck there for a while. Now I can proceed to install it with KDE.

2013-05-15, 14:40
You are right oloc, the only way to install the mini iso 32 or 64, is to uncheck "Pentest tools" into the Software selection step.

2013-05-15, 21:11
BTW @oloc there is this Packages list for example http://archive-2.kali.org/kali/dists/kali-only/main/binary-amd64/Packages for the amd64 maybe you can make some script to install the packages mentioned inside.

2013-05-18, 10:11
As already said previously, currently with the mini ISO 1.0.1 insallation, to avoid a crashed installation, we have to unchek the "Kali pentest tools".
And a kali dist' without the kali tools is not exactly what we want.

You can read all the posts of thus thread in order to understand why I checked the Packages file. Anyway with this interesting reading I found out that the package named kali-linux-full is the quicker way to install all the kali stuff.

You can try to install with "Applications > System Tools > Add/Remove soft" and select "Penetration testing and security auditing distribution, full system" but without success (due to the known dependencies issue).
So I suggest to install in the old school way : Terminal and commands.

In a terminal, with my root account I check what I discover in my "Packages file readings" with:

aptitude update
aptitude show kali-linux-full
aptitude show kali-linux

Everything seems to be similar of my readings and was as expected, so I launched :

aptitude update && aptitude install kali-linux-full
... and the result is this:

The following packages have unmet dependencies:
libopenvas6 : Conflicts: libopenvas5 but 5.0.4-1kali0 is to be installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) greenbone-security-assistant [Not Installed]
2) kali-linux [Not Installed]
3) kali-linux-full [Not Installed]
4) libopenvas6 [Not Installed]
5) openvas [Not Installed]
6) openvas-administrator [Not Installed]
7) openvas-cli [Not Installed]
8) openvas-manager [Not Installed]
9) openvas-scanner [Not Installed]

Then I select the option 4. This choice is due to the package description and because I prefer to eventually upgrade this lib later.

Accept this solution? [Y/n/q/?] 4
Action "4": Removing libopenvas6

Package: libopenvas6
State: not installed; will be installed
Version: 6.0.0-0kali1
Priority: optional
Section: libs
Maintainer: Stephan Kleine <bitshuffler@opensuse.org>
Architecture: i386
Uncompressed Size: 1,885 k
Depends: libc6 (>= 2.7), libgcrypt11 (>= 1.4.5), libglib2.0-0 (>= 2.30.0), libgnutls26 (>= 2.12.17-0), libgpg-error0 (>= 1.10), libgpgme11
(>= 1.2.0), libksba8 (>= 1.2.0), libldap-2.4-2 (>= 2.4.7), libpcap0.8 (>= 0.9.8), libssh-4 (>= 0.5.0), libuuid1 (>= 2.16)
Conflicts: libopenvas1, libopenvas2, libopenvas3, libopenvas4, libopenvas5, libopenvasnasl1, libopenvasnasl2
Replaces: libopenvas1, libopenvas2, libopenvas3, libopenvas4, libopenvas5, libopenvasnasl1, libopenvasnasl2
Description: remote network security auditor - shared libraries
This action was selected because libopenvas6 conflicts with libopenvas5
The installation finish without more issue, but I really do not know if all the pentest tools work. Of course, if I discover other issues with my installation, I will post it here in order to help the community to solve this trouble.