View Full Version : Wirless LAN Hard blocked, help (RF-kill doesn't work)

2018-07-21, 17:18
Since today my airplane mode hasn't turned off, it's stuck, and I can't turn on WiFi or Bluetooth, it says "Use hardware switch to tur..." I cannot read the whole sentence.

I tried a lot of commands:

rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes


rfkill unblock 0
rfkill unblock all
rfkill unblock wifi

But it always shows hard blocked: yes

My wireless card is: rt2800pci

If I ran 'airmon-ng start wlan0' it works, but if I ran 'airmon-ng start wlan0mon' doesn't work.

Or if I ran 'airodump-ng wlan0mon' it shows:

ioctl(SIOCSIFFLAGS) failed: Operation not possible due to RF-kill
Failed initializing wirless card(s): wlan0mon

My laptop is Asus P550L; 3,7 GB ram, Intel core I3

Can you help me please? It is so annoying

Sorry for english I'm italian.

2018-07-21, 18:41
The complete sentence is most likely: "Use hardware switch to turn on Wi-Fi".

There is a switch on your computer to enable/disable Wi-Fi or it can be in the BIOS too.

There is nothing rfkill can do if it is hard blocked.

2018-10-11, 17:41
On some laptops if you are dual booting Linux with Windows, Musket Teams have seen cases where to get the receiver to work with Linux you must first boot into Windows, turn the wifi system "On" under Windows then rebooot into Linux.