View Full Version : Release file InRelease is not valid yet (invalid for another XXh YYmin ZZs)

2018-10-08, 14:50
Hi all,

I'm trying to build a custom kali both a vm and iso using packer tool. it has been very frustrating to get this error message during the build,

E: Release file for http://http.kali.org/kali/dists/kali-rolling/InRelease is not valid yet (invalid for another 2h 56min 0s). Updates for this repository will not be applied.

Looked like the rolling release is kept being updated during the day. which make it impossible for me to build. I'm wondering if there is any workaround to this invalid period,

1. is there any repo from a stable release to use (such as 2018.03 release)?
2. is there any specific mirror site to use so I can avoid the invalid period?
3. any other workaround?


2018-10-08, 21:45
1. No distribution has a static repository, it is always being updated
2. You can try a different mirror from https://http.kali.org/README.mirrorlist
3. Always remember that Kali is based on Debian testing, so in this case, when searching online, pretty much any solution for Debian or Ubuntu should work (with some adaptation obviously). I haven't checked this but the error message matches yours and there seems to be a solution https://askubuntu.com/questions/1049411/release-file-is-not-valid-yet-and-other-errors-when-running-apt-get-update

2018-10-09, 15:06
Thank you for your inputs.
1. Correct, no repository is static. but what I need is relative stable release. where you can find a good time window so you can build a custom Kali, i mean during your build period, it won't make Release file invalid in between. When you're already in the build process, suddenly in the middle of nowhere, the Release file becomes invalid, it voids your whole build process. it really wastes time, very frustrated.

At some time I like the kali rolling release which continues rolling out new updates, never need to reinstall OS like traditional release base. But now for build purpose, I like to have a traditional release base for build purpose. the previous kali release is just too old for a base as now.

2. yes, I already tried a mirror but which experiences the same issue. I think the mirror is in sync with master repository all the times.

3. Had found this post from google. it's a different issue, not helpful to my situation.

Anyway thanks again for your prompt response.

2018-10-15, 22:44
1. The time on the specific repository might have been incorrect at the time of the sync.
2. How many mirrors have you tried?

Have you tried again in the past few days?

2019-03-15, 00:17
i guess solution is set your system time and use "sudo" before apt-get update.

2019-03-15, 20:42
I have a laptop that consistently lose time and before I do anything, I have to sync the time.

Run 'date' in the terminal to confirm the time is good.