View Full Version : Why is USB wifi for AWUS036ACH not usable?

2019-01-07, 17:38
I've been wondering this question for the past two weeks. And that's because I've tried my
darness to make this card work but it doesn't.
1) I've installed the headers
2) Installed the upgrade
3) installed the Realtek drivers
4) some other configurations or runner commands to find out where the card is

But to my amazement nothing has worked. I've also just read that one must run the
Rfkill unblock wifi. Does the OS automatically block cards or is it just a happenstance
and it's yet another command to run to try to make the OS see this USB device?
I have the latest OS, 2018.4 and on vmware and vbox...
Thanks for your advise.

2019-01-07, 22:54
Could you explain what you mean by not usable?

Are you having issues plugging the card?
Are you having issues installing the driver?
Are you having issues connecting to an access point?
Are you having issues putting the card in monitor mode?

Basically, could you provide more information on what you are doing, what the result you are expecting and what you're getting instead.

2019-01-08, 14:53
Good morning Mister_X,
So, I have tried to make the OS see this USB Wifi card but it fails. I've installed the driver's (apt-get install Realtek-rtl88xxau-dkms) and the vm doesn't see it at all. I've checked the log messages and nothing is wrong (dmesg, lsusb). The vm does see the network card on the device (laptop) and I've been able to do (apt-get update, apt-get upgrade).
I've gone on the Internet searching for the actual drivers (c code and Makefile files) but I ran into wrong and depencies which make the process fail. I didn't know this would be a nightmare to use? Btw, I've used vmware and vbox. Thanks for your interest Mister_X.

2019-01-16, 13:23
I've always found wireless work to be problematic from within a virtual machine. Can you use the card on a bare-metal install of Kali?

2019-01-16, 19:37
Hi grid,
That's actually my next step, I need to do that this coming weekend.

2019-01-16, 21:06
apt-get install Realtek-rtl88xxau-dkms is the right thing and if it ended up being successful (if it failed, you'll see an error message), there is no need to install anything else.

Never had any problem with USB on a VM. All you have to do is attach the USB to the VM (Somewhere in the menus). Make sure the USB port of the VM is set to 3.0.

2019-01-17, 01:15
Hi Mister_X,
I only wished it would've been that easy for me. Unfortunately, this is my 4th week and it still doesn't work. I had it in vmware and it didn't work. I created a vbox and tried everything and it didn't work. Before that, I had tried every possibility listed on this thread or on the wide internet.