View Full Version : Mac address spoofing does not work (macchanger)

2013-05-05, 19:21
Hi everyone.

I have noticed that spoofing a mac adress to connect my computer to a hotspot prevents me from connecting to this very hotspot... Sometimes, I can connect to the router but no webpage is displayed (it loads indefinitely).

I have precisely followed these steps:

-First: service network-manager stop
-Then : airmon-ng start wlan0 (enabling monitor mode)
-airodump-ng mon0, followed by a airodump-ng --bssid MAC_address_of_the_hotspot mon0. Then I got the MAC address of someone connected to the hotspot.
- I quit airodump, then I did "ifconfig wlan0 down"
- macchanger -m the_mac_address_I_got_2_steps_earlier wlan0
-ifconfig wlan0 up

At this point, "ifconfig" shows me that the mac address is spoofed (yeay!).

Still, I can't connect to the hotspot...:mad:

Any idea, any help?


2013-05-05, 23:02
For some reason, it seems wrong to have the mac of another system on the network....not sure if it would have to much effect but...yea. the arp table would more than likely send data to the original. Try using the -r syntax to generate a random mac

2013-05-06, 10:09
You cant have 2 people with the same MAC Address connected to any access point at the same time you have to wait till the other person to get off to connect and your probably also kicking them off every time you try to connect.

2013-05-06, 11:03
I was using my second computer's mac adress... I disconnected it from the hotspot before spoofing its mac address... And still, I could not get any access to the web, despite the fact I was connected to the router.

2013-05-06, 12:53
so your connected to the hotspot. first see if it is actually assigning a ip address with "ifconfig wlan0" without quotes

2013-05-06, 13:01
I re-tried today. Actually, "ifconfig wlan0" doesn't show any ip, and I couldn't connect to the router this time.
I also tried macchanger -r wlan0 : same result.
Then, I remade all the steps starting with "airmon-ng check kill" : same result

Do you think the issue is due to my wireless card (Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller)?

This is really strange.

2013-05-06, 23:06
Maybe it is due to NetworkManager... I'm gonna try with wicd and I'll keep you informed

2013-05-07, 19:23
Wicd did not fix the issue... Some help is needed here!