View Full Version : Burning ISO CD not DVD

2019-03-16, 05:35
I'm working with Kali 4.19.0-kali3-686-pae.

I decided to download the Parrot Netinstall ISO to give that a try on a new computer - it's a small file and I have extra CDs laying around. I didn't want to use any of my flash drives for this cuz I've got them partitioned/formatted with backup images and programs already. So, I started with less /proc/sys/dev/cdrom/info and got returns to say I can burn CDs and DVDs (see below):

CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name: sr0
drive speed: 24
drive # of slots: 1
Can close tray: 1
Can open tray: 1
Can lock tray: 1
Can change speed: 1
Can select disk: 0
Can read multisession: 1
Can read MCN: 1
Reports media changed: 1
Can play audio: 1
Can write CD-R: 1
Can write CD-RW: 1
Can read DVD: 1
Can write DVD-R: 1
Can write DVD-RAM: 1
Can read MRW: 0
Can write MRW: 0
Can write RAM: 1

I tried using dd if=Parrot-netinst-gtk-4.5_i386.iso of=/dev/sr0 because I thought it was still good for CDs and got
dd: failed to open '/dev/sr0': Read-only file system. I tried growisofs and got
:-( /dev/sr0: media is not recognized as recordable DVD: 9 So I started grasping. I used mkisofs (obviously deprecated), cdrecord, mkdir /media/iso, and wodim, but I couldn't get any to work because they didn't either recognize SCSI driver or something wasn't writable, etc. I eventually installed Brasero and made the ISO, but what are my options if I want to use the terminal if I only have a small file on CD and not a full ISO DVD?

2019-05-04, 06:08
How can you say that these cdrecord, mkdir /media/iso, and wodim willl work?