View Full Version : 2019.3 Upgrade or Install from USB - Whitebox over desktop wallpaper / Menu items

2019-09-05, 19:03
I had a dual-boot Mac/Kali. When I updated from 2019.2 to 2019.3 I got a white box covering the background image. The white background/whatever this is also persisted for the menu drop-downs for both [Applications] and the [Top-Right Arrow]. If I clicked the [Top-Right Arrow] multiple times the white would go back to normal dark-grey for the drop-list. This trick does not work for the [Applications] menu and the white bleeds out the white text list. I tried fixing this by reinstalling the GRUB loader but I ended up hosing my Mac boot ability.

This morning I reinstalled Kali using 2019.3 and decided to go full disk install (no more dual-boot) which I am cool with and do not need to go back to this, at least at this time. However the same white box is persisting. I can get rid of the white box over desktop background by changing it to a solid color. However the white persists for the drop-menus. I thought this was a video driver issue at first but I do not think it is at all. I can open and run programs just fine. It is just this freakish white box that appears when any desktop background image is selected. (Tried selecting other desktop background images and the white box persists). In screenshots below you can see where the white box ends nearly 1/2" from bottom of screen so its not quite 100% fill.

Additionally, When the screen locks out I am unable to use mousepad to swipe up to open login option to get back into system.

My Hardware is a mid 2015 MacBook Pro. No longer any dual-boot (due to trouble-shooting the issue) and is now straight 100% Kali.


Please help.

2019-09-07, 15:44
Update, I reinstalled with Kali 2019.2 and I do not have this issue. Tried updating/upgrading to the 2019.3 version and the issue comes back. Reinstalled 2019.2 and the white box issue is not there. I do not know if this is an issue with other computers but it is with my Macbook Pro mid-2015. Hope this helps. I am sure I am not the only one experiencing this problem. Love Kali and what you offer!

2019-11-13, 13:04
I have exactly the same issue! Is this a known bug?

2019-11-26, 10:52
Is there a way to downgrade the xorg system? Any other suggestions to debug this problem? Tnx

2019-12-08, 08:35
I also have this exact same issue on a fresh install of Kali 2019.4 on a 2016 Mac Book Pro. The background of the desktop is all white except for the bottom inch of the screen where I can see the bottom of the background image. When I open a browser and scroll, it appears that a white box covers the majority of the browser. When I stop scrolling I can sometimes see all the content in the browser. When I click off the browser to another application, the browser white box covers some of the content again.

I am not dual booting and I am using encryption LVM with home, var and tmp in different partitions.

Radeon HD 8870 / R9 M270X/M370X
Subsystem Apple Inc. Radeon R9 M370X Mac Edition
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

If anyone has any information to overcome this it would be greatly appreciated.

2019-12-09, 03:25
I am dealing with this same issue on -

Mac Book Pro 2016
Full disk install, full disk encryption, LVM
Kali 2019.4
GPU - AMD/ATI Venus XT [Radeon HD 8870M / R9 M270X/M370

Any help would be greatly appreciated. I have reinstalled trying KDE and Gnome. Both have the same issue.

2019-12-09, 03:33
I am dealing with this same issue on -

Mac Book Pro 2016
Full disk install, full disk encryption, LVM
Kali 2019.4
GPU - AMD/ATI Venus XT [Radeon HD 8870M / R9 M270X/M370

Any help would be greatly appreciated. I have reinstalled trying KDE and Gnome. Both have the same issue.

2019-12-14, 08:27
Same issue here ...

Mac Book Pro 2016
Radeon M370X
Kali 2019.4

2019-12-25, 15:33
It seems the problem is the incomplete optimization with mac display. It is fixable though. You just have to lower your kali resolution with settings->display

2020-01-01, 03:45
Thanks @GaZZ, I went through each resolution all the way down to 800 X 600 till it worked.

I can confirm that 800 X 600 on a 2015 Mac Book Pro works. Each applications is now working without the white overlay blocking the content.

Funny thing is I went out and bought a new Dell XPS 7590 after giving up on fixing this issue with the Mac Book Pro...

2020-01-03, 11:11
I've had similar issues with that and learned the fastest way to correct it is, lower resolution, then select desktop background, select wallpaper again, then back out and refresh screen. Alot of times it happens with VM ware due to memory/resolution issues. hope this helps.

2020-01-06, 08:15
Same issue here. I have a MacBook Pro mid2015, I just did a dual boot again with the latest Kali and this happens. I tried several releases, the last working one is 2019.2.

2019.3 and 2019.4 both have this issue, either with Gnome or XFCE. Rebooting, changing the background etc won't help. Changing the resolution to 800x600 does, but seriously, who can work with that?

I believe it has to do with some firmware change for the AMD Graphics card (I have a Radeon M370X), but can't know for sure. There were some firmware files missing under /lib/firmware/amdgpu/, but even replacing them from the linux-firmware git branch of Debian didn't help.

How to troubleshoot this?

2020-05-21, 12:50
Installed latest version today... issue still persists. This issue is sooooooo annoying! :mad:

2020-05-25, 01:37
Yes, same issue. Dual boot, MacBook Pro. (2020.2)

2020-06-29, 19:53
*BUMP* :confused:

cold iron
2020-07-04, 13:39
I had the same thing, hated the white. Dumped it and went back to the early version.

2020-07-07, 07:32
You must have chose a wrong one that i presume to be the "Kali Linux 64-Bit (Installer) (https://cdimage.kali.org/kali-2020.2/kali-linux-2020.2-installer-amd64.iso)". You needed to boot this one "Kali Linux 64-Bit (Live) (https://cdimage.kali.org/kali-2020.2/kali-linux-2020.2-live-amd64.iso)". Sometimes when you are in haste your mind doesn't support much.

2020-08-24, 15:29
UPDATE.... this problem continues to persist for my hardware. Even after all the updates and yes to anyone who thinks working on a system stuck in 800 x 600 you try it for a full day and tell me it is usable...... Some of the programs have windows much larger than 800x600 and there is no workaround for that.

Parrot Security OS does the exact same thing so I thought it was a problem with Debian. Again, no virtual machines used here. I installed and ran each one native. Ubuntu however, which is Debian does not have this problem. I do not want to switch to Ubuntu native then run Kali through virtual machine but I am still forced to due to this.

Is there any permanent fix for this.... I know it's Kali and once you do an update you have to go back a redo most fixes, but if we can get to a usable baseline then it's a start. Plus I want to learn more about SDR technology and using SDR peripherals through a virtual machine has lag issues. Running Kali native resolves the lag of SDR peripherals.

2020-08-27, 15:44
Just so you know.... I did try both versions already. In addition to previous efforts I tried both versions again today using versions 2020.3 and both installs result in he white box which makes Kali un-useable for me.

Why would you think that a live vs install version of 64-bit Kali make any difference?

"Sometimes when you are in haste your mind doesn't support much." - hubris does not suit you....

cold iron
2020-08-28, 15:50
Seems odd to call the program "Installer" when it is not! And call the right one LIVE is ambiguous. Just saying!

2020-11-01, 09:01
Same problem still here... Wakey wakey rise and shine guys! Thank you

2020-12-14, 07:47
Anyone find a way to fix this? I have the same and tried all sorts of things like install different package and missing firmware files, but still got this white blobs blocking the screen.
Yes, 19.2 seems to work, but not beyond that.
Kali 2019.2 is Kernel 4.19.28, GNOME 3.30.2 whereas 2019.3 is Kernel 5.2.9, GNOME 3.30.2 so seems to me the clue is in the kernel version. Ubuntu 20.04 runs 5.4.0-58 and works fine.
I am beginning to think it is not worth trying to run Kali on a macbook.

2021-03-20, 08:16
Anyone found a solution for this? It is related to kernel version 5 in Kali. Those working versions use kernel 4.x. It is rather annoying given that Ubuntu works fine and that uses kernel 5.x