View Full Version : Nethunter on Gemini 4G PDA

2019-11-07, 10:25

I'm trying to get Nethunter working on my Gemini 4G but still not "completely" success... Here is what I did:

I tried the Re4son guide and create a new layout with 4 boots: Android 8.1 rooted - stock recovery - TWRP - Kali Linux. All of them are working fine. However when I try to install the Nethunter ZIP installed using TWRP I got an error because /data is encrypted and it cannot be decrypted... I tried a lot of things to disable encryption with no success, so I ended up by installing Nethunter "manually"

I installed the APKs from Nethunter and the chroot image and install it that way. I had to use the minimal chroot and from there I did a dist-upgrade to get everything. So far so good, everything seems to work and Nethunter is installed... HOWEVER my Realtek USB is not recognized, this is where I figured out that I need to use a custom kernel.

By inspecting the ZIP installer I saw a boot-patch installer. I modified it to not try to mount /data (since isn't needed) and install it using TWRP. Apparently everything went well but after rebooting the old kernel was still in place....

I modified again the boot-patch installer to get a copy of the patched boot.img and I flash it using SP-Flash Tool... afterwards I only get a boot loop....

So this is where I am, if I flash the boot.img I get a boot loop...

I saw the source code for the kernel (https://github.com/Re4son/gemini-kali-linux-kernel-3.18) and I will try to compile it myself. However it's being long time since my last kernel compilation and it would be my first one on Android, so I'm not very confident that this will work either.

I was able to compile the kernel (with so much work) but after replacing it on the boot.img I get the same result: bootloop :(

What am I missing? Can you share your boot.img so I can flash it?

I'd appreciate some help here

Thank you!

2019-11-14, 00:04
yea what was the best firmware/ nethunter combo since all the old firmware is available