View Full Version : Having trouble installing Kali Linux amd 64 did not detect and mount CD-Rom

2013-03-23, 16:24
Yes.I am having trouble installing Kali Linux amd 64 on my Dell Inspiron Laptop.

The installer failed to detect and mount CD-Rom.

But the live USB works perfect.

I'll tell you exactly how I downloaded and used the USB.
First I downloaded Kali Linux from another computer which is a desktop Windows Vista 32 bit Operating System,after the download I put the USB into the socket then I used Win32 Disk Imager and clicked on the option "write" then then I transfer all that to my laptop which unlike my desktop this is a linux 64 bit Operating system before I attempted to install Kali Linux I tried it as a live usb after it was all successful and even had a perfect wifi connection and very fast internet connection and responds time I finally decided to install this wonderful product but I was not too successful it kept saying it could not detect and mount CD-Rom so eventually I decided to take a snapshot of the error messages.

The error messages are located at: /var/log/cdrom-detect_no-release_0.png

and: /var/log/debian-installer_main-menu_item-faliure_0.png

I honestly could not find them

2013-03-24, 15:15
Maybe we can troubleshoot this, but will need a little more info; Using a liveUSB can you please let us know what the command output of this is:

2013-03-25, 04:42
Check the fstab file: cat /etc/fstab

See if it is as /dev/sr0.

Also check if it is located at: /media
must be as "cdrom"

please, post info.

2013-03-25, 23:45
I'm having the same problem, I was wondering if the iso is corrupt, on the download page the SHA1 is: 619b1ffb72b8c72fa341adccdf4ecbadedacec6e but no matter how many times I download it or what browsers or computers I use I get 154013C2219B6B0DE23AC565842262FA3D156B98.

ISO doesn't work for install either through USB or burned to a DVD, however in both cases the live boot function works.

Would be happy to try additional steps as requested.


2013-03-26, 03:22
I re-downloaded the ISO and with Internet Explorer (I know blah) and it worked like a charm.

2013-03-26, 03:28
Disconnect CDROM, install, power off, reconnect cdrom, turn on machine and see if it sees it..

2013-04-08, 02:14
I had this same problem with Kali 1.0.1 while trying to install to a VM. It did not appear the cdrom drive was being mounted. After mounting the drive and returning from the shell the install still failed looking for the 'Release' file. I found 4 'Release' files and before I continued troubleshooting I noticed there was a bug fix release (1.0.2).

Kali 1.0.2 installs fine for me so give that version a try.