PDA

View Full Version : Cowpatty invalid option



Sidewalker
2013-05-10, 07:54
Hello.

Sorry for maybe noob questions, but google doesn't help.


I have installed latest Kali (Linux kali 3.7-trunk-686-pae #1 SMP Debian 3.7.2-0+kali6 i686 GNU/Linux) and then trying to use john + cowpatty (as a following of the one book guidance). And getting error in cowpatty: invalid option -- '2'

john --wordlist=lower.txt --rules --stdout | ./cowpatty -f - -s RZRNET -r hackmeup-02.cap -2

cowpatty 4.3 - WPA-PSK dictionary attack. <jwright@hasborg.com>
cowpatty: invalid option -- '2'

How to fix this? I need this option...


I think it can be not enough new version of cowpatty in Kali (cos, as writing author of cowpatty in his blog, I need v. 4.5 or higher to use option "2") and downloaded new version (4.6), then build it. But if I trying to use just that new version, error still exist...

john --wordlist=lower.txt --rules --stdout | ./cowpatty -f - -s RZRNET -r hackmeup-02.cap -2

cowpatty 4.6 - WPA-PSK dictionary attack. <jwright@hasborg.com>
./cowpatty: invalid option -- '2'


And another question - how to update current version of cowpatty (4.3) in Kali to 4.6?
I.e. replace the current to the 4.6. In google was only guide how to download and build.

And why in newest Kali is too old version of cowpatty? Version 4.3 was released at March 20 2008, and 4.5 at July 03 2009.

Thanks a lot!

g0tmi1k
2013-05-10, 09:18
I also ran into the same issue a few days ago.




How to fix this? I need this option...

I've submitted a bug report (http://bugs.kali.org/view.php?id=336) to get coWPAtty upgraded.

So the best fix for it, wait for the repo version to be updated.
This is the easiest method & only way to guarantee long term support.
Reasons why not to manually update can be found here: http://www.kali.org/kali-monday/bleeding-edge-kali-repositories/




I think it can be not enough new version of cowpatty in Kali (cos, as writing author of cowpatty in his blog, I need v. 4.5 or higher to use option "2") and downloaded new version (4.6), then build it. But if I trying to use just that new version, error still exist...

john --wordlist=lower.txt --rules --stdout | ./cowpatty -f - -s RZRNET -r hackmeup-02.cap -2

cowpatty 4.6 - WPA-PSK dictionary attack. <jwright@hasborg.com>
./cowpatty: invalid option -- '2'

You also need to patch cowpatty afterwards, see here: http://bugs.kali.org/view.php?id=336#c439




And another question - how to update current version of cowpatty (4.3) in Kali to 4.6?
I.e. replace the current to the 4.6. In google was only guide how to download and build.

And why in newest Kali is too old version of cowpatty? Version 4.3 was released at March 20 2008, and 4.5 at July 03 2009.

Manually upgrading programs isn't recommended, nor supported by us.
For reasons why: http://www.kali.org/kali-monday/bleeding-edge-kali-repositories/

will ultimately break your install in the future.


My guess would be cowpatty came from the Debian repositories, and its also out of date.