PDA

View Full Version : OpenVPN not working in network connections



ANimo78
2021-02-27, 12:40
Hi guys and girls,

I'm fairly new with Kali Linux and Linux in general.
Most things I can figure out with a little help from my buddy Google.
Unfortunately this isn't the case here and it even puzzled NorthVPN Linux support.
So I though lets try the experts.

First of all I run Kali Linux 2021.1 x64 on a Raspberry Pi 400.

I import a configuration file for OpenVPN, doesn't matter if it's from NorthVPN, TryHackMe or other.
I can click it what I want in Network,(top right next to clock) VPN connections, OpenVPN but nothing happens.
TryHackMe has a tool which checks the OpenVPN connection and tries to restore it,
I says that tun0 is not present, after it tries to corrects it, OpenVPN can connect, but the data still doesn't use the VPN but uses eth0.

When I change the config in NetworkManager.conf managed=true, reboot and try again,
OpenVPN starts up but all data goes through eth0.

sudo apt-get upgrade en upgrade, don't help either, nor complete reinstallation

I hope someone here can :(