View Full Version : USB adapters can't see wireless networks from ax routers

2021-03-03, 09:49
I've been having trouble with 802.11ax routers and wifi usb adapters in windows, specifically, my clients can't see the networks from them at all. I've tried 2 different ax routers (Asus RT-AX55 and Netgear RAX 45) and 2 different dongles (TP-WN823N and Alfa AWUS036AC). The wifi adapters work just fine for my other older routers, and I have laptops that are ancient that can see the wifi networks coming from the ax routers.

I've tried both wifi usb adapters on 2 different computers but neither computer can see any network from either router. I then tried running through all kinds of different wireless settings for the routers (disable ax mode, tried different channels, tried setting the bandwith to 20 MHz, 40MHz) but to no avail.

I then tried the AWUS036AC adapter on kali using airodump and that was successful in seeing the networks from the ax routers, so that makes me think it's some kind of windows driver issue.

Has anyone run into an issue like this before? This is not a kali linux problem, but I'm hoping someone in here that's done quite a bit of poking around wireless networks might have some clue as to what's going on, because I'm out of ideas.

Thanks in advance.