View Full Version : Dual-Boot with latest Win 10 and UEFI/GPT; Can lvm be made to work again?

2021-03-31, 16:47

I had installed Kali linux, say 4-5 years ago with success in a dual-boot. I've used encrypted lvms, resized them, etc.
I worked many years as a systems engineer/administrator in various places.

Most recently, I have installed the latest Kali linux on two dual-boot pcs that also have the latest Windows 10 with updates.
They are both UEFI and GPT formatted. I had converted both of them from MBR formatting inside windows with a dos utility. They both have an option in the bios to boot legacy/MBR formatted devices.

The first pc is a late-2015 Dell XPS8900 desktop with 6th gen Intel I7. This is the one I am currently reinstalling and have questions on.
The 2nd pc is a mid-2012 HP Pavilion dv6-7000 laptop with 3rd gen Intel I7. This is working satisfactorily.

The desktop Dell on my first successful go-around with these recent installs, I was able to manually configure an lvm vg and 6 logical volumes (/, /usr, /opt, /var, /home and swap lvs), pick somewhat arbitrary sizes (but informed) within the GUI installer program. I was able to install the system completely, although the installation's grub configuration did not recognize the windows installation and on boot, I had just the Kali grub menu choices.

Wanting to keep my Windows 10 intact, I fixed the windows bootrecord with such tools as bootrec /fixboot, bcdboot c:\windows /s, diskpart etc. I'm sure you recognize this activity.
Somehow, (as I stepped away from the gui installer at that point), grub was put on 1 of the lvs (root I think in the /boot directory?) rather than on the NTFS /dev/md126p1 system volume, though that volume had the Kali folder under \EFI\Microsoft\Boot- just empty. In any case it was fine and satisfactory. I could now go into the bios and select kali, rather than having grub handle things and offering windows or Kali to boot.
If that makes any sense. I kind of like that one had to F12 into bios to see Kali, and not get a Kali blue screen grub menu blasted at you. It was hidden.

Why did I choose lvm and logical volumes? My 4-5 year old experience I guess and diving in. And it worked this first time. But maybe I got lucky with the lv sizes or just lucky in general.

Roll forward. I am trying to get back to that. I am trying to reinstall this Dell desktop system. I had blown the partition away in windows.
With the laptop, I read more closely Kali's dual-boot with windows installation guide. I chose guided partitioning with every mountpoint in one partition.

Everything is fine up until the penultimate step of additional software- it fails at about 95%, consistently now. I'll catch a screen shot, but it doesn't offer that much.
I think it's a space issue, no space left on device, etc. Can I see anything useful if I go to a shell at the main install list of steps? And what log? This is not the "live" usb but the "gui installer"
I also ran into this error and same spot with the laptop's install.

Long-winded, sorry. So a couple of questions:

The Dell has Intel RST chip on board, and I have a RAID-0 setup- two 1TB drives for a 2TB volume. The nice thing is that gui installer runs the mdadm commands to assemble the md device behind the scenes.

1) Can manual lvm partitioning be made to work (again, cause it did initially)? Does someone who has this working have recommended sizes? I had:
/ 15G
/usr 7.5G
/opt 7.5G
/var 2.5G
swap 1.5G
/home 1.8T

2) Asked above, but what logs during install can give more about additional software installation failures and how to get there?

3) Should I just install guided partioning, every mountpoint in same partition as I had done with the laptop? I am probably going to hack away in this direction, and not necessarily wait for an answer.
But, answers will be welcome in any case for future.

4) On this Dell system, I cannot format the usb installer iso as UEFI/GPT in Rufus. On install, it always gives error of " can't mount media". Something seems locked in uefi. The usb iso has to always be MBR Fat32 formatted, is that right?
Multiple reburns of both live and installer isos up in Windows.

There are tons of hiccups, gotchas, kludgy behavior with a same disk install and co-resident Windows. Frustrating. Maybe this is UEFI-related. I don't remember these problems from 4-5 years ago.
Thank you on the questions.

Thanks for reading.

2021-04-01, 00:43
I've got this Dell installed again. Had to forgo the lvm and choose guided partitioning, all files in the same partition.
Still would like to know on one of my original questions:

1) What logs can be reviewed on the usb installer for late install problems- especially generic additional software failures?

The layout:

parted /dev/md126
GNU Parted 3.4
Using /dev/md126
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p
Model: Linux Software RAID Array (md)
Disk /dev/md126: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 108GB 108GB ntfs Basic data partition msftdata
4 108GB 1999GB 1891GB ext4
5 1999GB 2000GB 1023MB linux-swap(v1) swap