PDA

View Full Version : apt stuck on dependency loop?



taklukali
2021-04-14, 06:08
So I opened my Kali VM after a long time, is 2019.4 and I tried installing synaptic then I get this error
I tried fix-broken and individually installing the dependencies but they lead to each other and none can be installed, I do not want to do a full system upgrade as that would remove my root priv as 2020 kali dose'nt allow root iirc, so please help me out!
Thanks for reading, have a great day/evening!


apt install synaptic
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
clang-8 : Depends: libc6-dev but it is not going to be installed
Recommends: llvm-8-dev but it is not installable
libc-bin : Depends: libc6 (< 2.30) but 2.31-9 is to be installed
libexpat1-dev : Depends: libc6-dev but it is not going to be installed or
libc-dev
libstdc++-8-dev : Depends: libc6-dev (>= 2.13-5) but it is not going to be installed
locales : Depends: libc-bin (> 2.31) but 2.29-9 is to be installed
synaptic : Depends: libapt-pkg6.0 (>= 1.9.0) but it is not going to be installed
Depends: libept1.6.0 but it is not going to be installed
Depends: libxapian30 (>= 1.4.14~) but it is not going to be installed
Recommends: libgtk3-perl but it is not going to be installed
zlib1g-dev : Depends: libc6-dev but it is not going to be installed or
libc-dev
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).