View Full Version : Raspberry Pi 4 8GB USB boot; start4.elf: is not compatible

2021-05-06, 12:23
Has anyone been successful in booting the Raspberry Pi v4 from USB?

I have been successful in booting on a Pi v3 B+, using this as a guide: https://raspberrypi.stackexchange.com/questions/106762/how-to-install-kali-linux-on-a-usb-for-the-raspberrypi

However, I am unable to boot on a v4. I have performed the following;
- boot from latest Raspian on micro SD
- ran `rapsi-config` and updated the bootloader to latest (also tried factory)
- enabled USB boot if SD not available (also tried vice-versa)
- performed the steps outlined in https://raspberrypi.stackexchange.com/questions/106762/how-to-install-kali-linux-on-a-usb-for-the-raspberrypi

The Pi will never boot, instead it hangs on the start screen with the following errors:

Raspberry Pi 4 Model B 8GB
bootloader: c2f8c388 Apr 29 2021
update-ts: 1619712685

board: d03114 1fbc6018 dc:a6:32:fe:2a:5d
boot: mode USB-MSD 4 order f41 retry 1/128 restart 2/-1
SD: card not detected
part: 0 mbr [0x0c: 00000800 0x83:00040000 0x00:00000000 0x00:00000000]
fw: start4.elf fixup4.dat
net: down ip: sn: gw:
tftp: 00:00:00:00:00:00

Trying partition: 0
lba: 2048 oem: 'mkfs.fat' volume:' BOOT '
rsc 32 fat-sectors 2001 c-count 256062 c-size 1 r-dir 2 r-sec 0
Read config.txt bytes 2236 hnd 0x000220bl
HUB [01:00] 2.16 000000:01 init port 3 speed 1
Read start4.elf bytes 2252288 hnd 0x00017209
Read fixup4.dat bytes 5398 hnd 0x000002ec
Firmware: 3a8f1793b758d6fb7f375edaa260e069ecd34c88 Apr 27 2020 14:33:37
Ox00d03114 0x00000000 0x0000000f
start4.elf: is not compatible
USB-MSD boot requires newer software
Get the latest software from https://www.raspberrypi.org/downloads/

I have also tried this other post I found here; https://forums.kali.org/showthread.php?49970-RPI4-USB-Boot-for-Kali&highlight=raspberry+usb+boot

Any guidance will be much appreciated! :)