PDA

View Full Version : Realtek USB wifi adapter RTL8811AU Issue - Kali VM



Sceolan
2021-07-13, 16:22
I can't get my Realtek USB wifi adapter to work in Kali. I searched a lot for a solution but haven't found it yet. Any help would be much appreciated.

My setup:
- Laptop running Windows 10(64bit)
- Kali running as a VM inside Virtualbox
- Metasploitable 2 VM
- Realtek USB wifi adapter (802.11ac WLAN adapter [0200]. RTL8811AU chipset)

root@kali:~# uname -a
Linux kali 5.10.0-kali3-amd64 #1 SMP Debian 5.10.13-1kali1 (2021-02-08) x86_64 GNU/Linux

Issue:
I can't get my wifi usb adapter to work within my Kali vm. First i thought it had to do with my virtualbox network settings so the last couple of weeks i had contact with a moderator on the virtualbox forums and tried a lot of different network settings:

https://forums.virtualbox.org/viewtopic.php?f=6&t=103125&p=502550#p502550

In the end he said i had setup the required USB filter correctly and it is passed/captured ok to the Kali vm so the problem should be within Kali itself. And that it should work regardless of
the network setting in virtualbox. So i disabled the network adapters in virtualbox and tried to startup the Kali vm, but i can't get a internet connection this way. That's why he referred me to this support channel/forum.

The adapter is listed as usb device:

root@kali:~# lsusb
Bus 001 Device 002: ID 0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I tried installing drivers in Kali in the following way:

wget https://http.kali.org/kali/pool/contrib/r/realtek-rtl88xxau-dkms/realtek-rtl88xxau-dkms_5.6.4.2~git20210327.c0ce817-0kali2_all.deb https://http.kali.org/kali/pool/contrib/r/realtek-rtl8814au-dkms/realtek-rtl8814au-dkms_5.8.5.1~git20210331.bdf80b5-0kali1_all.deb
sudo apt update
sudo apt install ./realtek-rtl88xxau-dkms_5.6.4.2~git20210327.c0ce817-0kali2_all.deb ./realtek-rtl8814au-dkms_5.8.5.1~git20210331.bdf80b5-0kali1_all.deb

Here is the status:

root@kali:~# dkms status
realtek-rtl8814au, 5.8.5.1~git20210331.bdf80b5: added
realtek-rtl88xxau, 5.6.4.2~git20210327.c0ce817: added
virtualbox-guest, 6.1.22: added

root@kali:~# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 8 bytes 400 (400.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 8 bytes 400 (400.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

root@kali:~# iwconfig
lo no wireless extensions.

I've looked at similar posts on this forum and googled a lot but no luck yet. I'm fairly new to this so excuse me if this a noob question, but i'm quite stuck

What else could i do within Kali to fix this?