PDA

View Full Version : Laggy graphics with Intel iris Xe graphic card on Dell XPS 9305



thatjuanjo
2021-09-06, 16:11
I am currently facing an issue with my new Dell XPS 9305 where the graphics on what seems to be all linux distros are very laggy (system info at the end of the post).

By this I mean that it seems that the screen doesn't refresh at a good rate and it looks as if the cursor or the system was frozen when in reality everything is working just fine.
One particular thing is that, if I move the cursor around an area of the screen, that area seems to get refreshed, but still the experience is quite terrible.

Another particularity that I have noticed is that this issue seems to surface when there is little graphic activity on the screen, for example, if I open a terminal and I leave the cursor idle the graphics will start to lag,
but then if I type
glxgears as soon as I hit enter and the gear animation shows the lag is completely gone...

Furthermore: if I make xorg use the fbdev drivers the issue doesn't happen, but I cannot use external monitors that way so it kindof sucks. And if I use the intel drivers and connect external monitors, the external
monitors would work just fine but the laptop built in monitor will sometimes work just fine and other times still be very laggy

here is the output of
inxi -GS


System: Host: kali Kernel: 5.10.0-kali9-amd64 x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Kali GNU/Linux 2021.3
Graphics: Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Display: server: X.Org 1.20.11 driver: loaded: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.3.5


In summary, this is all I have tried:


Use different distros of linux: Ubuntu 20.04, Ubuntu 21.04 Ubuntu 21.10, Kali 2021.2, Kali weekly W35, Kali 2020.3. In all of them the issue persists
Configure xorg to use the fbdev driver: This works to an extent, but doesn't allow me to use external monitors
Updated my bios to the latest one: No effect
Tried windows (yes, I went this far...): Issue somewhat remains until the drivers get updated.


Any thoughts?