View Full Version : Builded images failing at twrp as corrupted

2022-01-08, 16:28
Hello all! Happy new year, really hope it blasts for us all!

Just a heads up,

i've always liked building my nethunter images be it for angler or hammerhead (haven't tried for ticwatch yet)
but never had a problem (even modified sometimes the build.py to reflect a more recent version of the apps from the NetHunter Store anyway...


no big mistery, i like to remove the branding (even tho i install the wallpaper and the bootanim.zip afterwards) and to make the kernel apart (so that way i flash it right way after the android, opengapps, magisk and end up booting just one kernel in the end)

the images are failing at twrp saying they're corrupted even tho digest matched and i can extract them with Engrampa frontend with no problems.
One thing i noticed the file system image zip file isn't being downloaded (path problems probably) and i even tried downloading the file myself from
$ wget https://kali.download/nethunter-images/kali-2021.4/rootfs/kalifs-arm64-full.tar.xz
but no dice, so just a heads up it might be funky.

It was an 6p Angler with a recent cloned repository. (as in up to date for sure) it was a 2021.4 i was trying to build.
Kernel is OK tho.
Thank you.

rootfs file at https://kali.download/nethunter-images/kali-2021.4/rootfs/ looks like didn't got cleaned up.
there are .debs (1.5GB) in /var/cache/apt/archives/ (probably reason the 2021.4 file is twice the size of last version 2021.3)

Now i'm extracting the rootfs that comes with prebuilt 2021.4 inside my kali-nethunter-project/nethunter-installer/rootfs folder, hope it fixes it