View Full Version : Kali Linux install on USB3.1 flash drive for use on HP T620 Thin Client (non-plus version)

2022-01-09, 17:05
Kali users/developers,

I installed Kali Linux onto a 256GB MicroCenter 3.1 USB stick and it boots up on the HP T620 fine, but I never get any GUI to log into. I can shift to a text terminal and all seems fine. The HP T620 (an older system) has a Radeon 8330 graphics card in it. Can anyone offer any assistance on this? At one point it said your screen is locked in a few seconds you will get an unlock screen, but after 20 minutes, it never appeared.

When I did the installation form the live version (I had another USB stick with live on it) I never saw the graphical grub screen I had to just know how many times to hit the down arrow for the right selection. I had booted using non-UEFI mode I think and that allowed me to get it installed, but it had an option "force UEFI install?" and I said yes. As well, now it seems not boot at all on my GD8200 laptop as well (thats an older system that I presume has no UEFI), but doesn't a UEFI install include legacy boot capability?

I had initially tried just dd-ing the LIVE image to the stick and going the encrypted persistence route but that was a bust as it was impossible to update the kernel so I figured a full install was best (I wanted GNOME over KDE anyway).

Thanks in advance and stay healthy and safe from the thugs.

2022-01-10, 01:14
Kali users/developers,

I was going to delete the above entitled posting but then I figured perhaps there would be some residual utility for some other users to see what steps I took in pursuance of eventually effectuating a path of remediation to the issue.

1) I ran xrand to try to see if I could see what resolution was in use, but it said "Can't open display".
2) I ran Xorg -configure in order to let the environment generate its own /etc/X11/xorg.conf.d/filename-goes-here file but it did not help.

In the end, it was cabling! Yes...believe it or not! The variant of the HP T620 thin client (non-Plus version) that I have has no VGA port on it and has a serial port instead. However, it has two DisplayPort ports and so I had a cable that I got at Target for $6 that went from DisplayPort to HDMI and then I had another cable that I've used many times that goes from HDMI to VGA. Finally, I decided, let me try a different cable, so I picked up a DisplayPort to VGA cable (going directly) and viola everything began working!

I also realized my GD8200 laptop does not have a firmware that supports booting from a device that has a GPT partition on it, and I know the UEFI installation instantiated just such a configuration upon my USB stick.

Lastly, I did one more test...I tried to boot pfSense to perform an installation (the original reason I got the HP T620, to be a router for me betwixt my some several VLANs), and it too offered no video until I changed the cable as above too.

Hope someone running into such issues in the future will be well served by my consternation and circuitous troubleshooting methodologies.

Have a safe, blessed, healthy, and thug free year everyone!