View Full Version : After Nvidia driver installs, system reboot's to blank screen.

2013-03-26, 04:28
I can press c+a+f1 and log in that way so no big deal I lost the gui login. When I type # /etc/init.d/gdm3 start if says failed.
I have followed two different ideas on what would/should work but have had no luck.
-from Samiux
# apt-get install nvidia-detect nvidia-libopencl1 nvidia-opencl-common nvidia-support nvidia-opencl-icd nvidia-visual-profiler nvidia-glx nvidia-installer-cleanup nvidia-kernel-common nvidia-smi nvidia-alternative nvidia-opencl-dev libglx-nvidia-alternatives nvidia-kernel-dkms nvidia-cuda-toolkit nvidia-vdpau-driver nvidia-xconfig glx-alternative-nvidia libgl1-nvidia-alternatives nvidia-settings libgl1-nvidia-glx xserver-xorg-video-nvidia libcublas4 libcudart4 libcufft4 libnpp4 libnvidia-compiler libcuda1 libcuinj4 libnvidia-ml1 libxvmcnvidia1 libcusparse4 libcurand4 python-pycuda-doc python-pycuda-headers python-pycuda nvidia-cuda-doc nvidia-cuda-gdb
######### rebuild 2
# apt-get install nvidia-glx nvidia-kernel-dkms nvidia-xconfig
Same thing upon reboot both times. No gui login, just blinking _ , but I do have access to files command line. I can work command line if I must, but I'm thinking someone might have a helpfull hint.

I am running an XPS L702X quad-core, with a gt555m graphics card.

On another note the card worked in r3 with pyrit

2013-03-27, 22:43
I hae tried the same thing and now mine also boots to a blank screen.
I noticed mine did it after the Xorg configuration and checking the log file at /var/log/Xorg.0.log tells me there is a fatal server error - No screens found

Anyone have any idea how to fix that?

2013-03-27, 23:05
All I did to fix the problem is this:

Reboot and either use CTRL+ALT+F1 to login to my user or log in via recovery mode in the grub loader.
Once there I deleted xorg.conf and rebooted. System is back to normal. I'll keep looking for a solution to find the screen though and post here if I do.

Keep in mind that I never had an xorg.conf before and I have a backup if it needs to be replaced. I suggest making a backup of it before you remove it

2013-04-25, 20:49
just rename your xorg.conf and then startx or reboot if you must have your desktop. diagnose the problem, in the event of "no screens found", just add one with the res you want (usually pretty simple though, xorg wasn't meant to be complicated. google is your friend!)

2013-06-17, 20:46
Found this in a Debian forum, worked for me for install, had to follow readme for nvidia driver chapter 6 for setup.. but pretty easy to do.

aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms

*** Even better yet.. found this right here in the Kali docs section: http://docs.kali.org/general-use/install-nvidia-drivers-on-kali-linux

2013-06-25, 00:43
http://docs.kali.org/general-use/install-nvidia-drivers-on-kali-linux. This is a great help, except I have installed KDE desktop. When I go to ctrl + alt + f1 and attempt to install nvidia driver it fails because x is still running. Looking for answer on how to properly shut down X in kde environment

2013-06-27, 10:33
Login as root
Rename xorg.conf file.

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bkp
Reboot and you'll get your X back. Now you can troubleshoot.

To find out which X Manager is running:

service --status-all | less
Once you've identified it, stop it.

service kdm stop (to stop Kde X)
service gdm3 stop (to stop Gnome X)

Supported syntaxex service service-name-here {start|stop|restart|reload|force-reload|status}

2013-07-14, 01:11
Thanks for the info blackMORE. I had to run the command service kdm stop to fix problem. The nvidia driver installs fine, so it says. If I run the config utility to create xorg.conf I have to delete or more to be able to login kdm. I am still missing something. In r3 I had no problems installing nvidia.

2014-08-18, 19:17
here is the solution

ctrl + alt + f1 login to console

aptitude install nvidia-xconfig

wait for installation to complete

now you can type :




2018-01-26, 16:48
here is the solution

ctrl + alt + f1 login to console

aptitude install nvidia-xconfig

wait for installation to complete

now you can type :




I tried this, to no avail, BUT, it did bring up the booting processes now, but stops and then entire screen flashes at: "[ OK ] Started User Manager for UID 131", then after 5 minutes quits flashing, but stuck at command prompt at "Started User Manager for UID 131"
starting to hate Nvidia, but they are the video card monopoly now I guess.... dang I want to get out of the Winblows OS's, but this nightmare is worse

Kali Linux 2017.3 64bit
AMD Phenom4 processor
Dual boot Kali/Win7
Nvidia GT545
6gig DDR3

Hello, why are these Nvidia drivers so hellbent on screwing up Linux OS's?? Just put Kali 2017.3 here on an AMD 4-core Phenom9850 processor/AMD board. Have a Nvidia GTX545 in it. As with everyone else apparently, as soon as I installed Nvidia/Cuda package, after reboot, got the black screen (no cursor), but apparently the systems running because my shared internet connection is still working on this winblows laptop. My Linux expertise is minimal, only playing w/ it for a couple months now. I see where people say log-in with Ctrl+Alt+F1,...where do ya do this at??, I get no response. It's a dual boot system (w/ Winblows), I get the normal login, can boot to winblows, but select Linux, , it goes black, I can tell it's a resolution problem me thinks. I go to recovery, but just get a prompt after password...clueles what to do after that. Is there a certain time when to hit Ctrl+Alt+F1?? ...or is there anyway to get me back to a desktop? Thanks

2018-01-26, 20:21
Update: while trying to figure out which solution to try with the 101 "solutions" out there, I tried installing dmlight, and now I at least have a log-in and a desktop, but the default kali background is only about 1/2 showing on the right of screen, and theres nothing on the desktop, no task bar either. I can right click terminal and pullup firefox through terminal only.

lspci -nn | egrep -i 3d|display|vga
VGA compatible controller [0300]: NVIDIA Corporation GF116 [GeForce GT545 OEM] [10de:1241] (rev a1)

nvidia-smi fails because it cant communicate with the NVIDIA driver

hashcat -I
only thing comes up is "Device ID #1....and it just lists my CPU pthread - AMD Phenom 9850

Hope this helps with my needing help ;) ..Thanks

2018-02-21, 06:53
I just tried installing nvidia legacy drivers for an 8800 GT and blacklisted noveau, after rebooting the system, an error screen would appear saying that there was an error and I should log out and try again.
In that very moment I realized that there was a conflict because of the non existence of the Xorg.config file, the presence of the nvidia drivers and the noveau drivers being blacklisted. So in order to be able to log in again I had to delete all nvidia related files and un-blacklist noveau.

While on the error screen press Ctrl + Alt + F2 keys combination.
This should purge all nvidia files

#sudo apt-get remove --purge nvidia-*
If there is an error run this:

#sudo dpkg --configure -a
Then we force load the noveau driver on the next reboot

#echo 'noveau' | sudo tee -a /etc/modules

Then reboot the system and you should be able to normally boot.