PDA

View Full Version : kali arm 64 for raspberri pi 4 ,2022-1



virvivir
2022-02-18, 06:34
the kali arm64 for rpi 4b .just broken , new install ,after run update. when you run apt upgrade . keeps saying libwacom9 depends libwacom-common(=2.0.0-2) but 1.12-1 is to be installed ,
E: Broken packages

Fang_0
2022-02-22, 13:46
Try:
sudo apt reinstall libwacom-common && sudo apt reinstall libwacom-bin

Elegant
2022-02-24, 12:54
I have the same issue with VMware build (kali-linux-2022.1-vmware-amd64.7z)


┌──(kali㉿kali)-[~]
...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
libwacom9 : Depends: libwacom-common (= 2.1.0-2) but 1.12-1 is to be installed
E: Broken packages

I installed libwacom-common and was able to upgrade. I am not sure if I was not supposed to use the 'sudo' keyword.


$ sudo apt install libwacom-common

I only got two warnings during the upgrade and no errors


dpkg: warning: unable to delete old directory '/etc/polkit-1/localauthority.conf.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/polkit-1': Directory not empty

tekkelfred
2022-03-16, 15:15
I have the same issue with VMware build (kali-linux-2022.1-vmware-amd64.7z)


┌──(kali㉿kali)-[~]
...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
libwacom9 : Depends: libwacom-common (= 2.1.0-2) but 1.12-1 is to be installed
E: Broken packages

I installed libwacom-common and was able to upgrade. I am not sure if I was not supposed to use the 'sudo' keyword.


$ sudo apt install libwacom-common

I only got two warnings during the upgrade and no errors


dpkg: warning: unable to delete old directory '/etc/polkit-1/localauthority.conf.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/polkit-1': Directory not empty


This worked for me!
Thanks