PDA

View Full Version : Kali Linux Network PXE install



muts
2013-02-01, 13:20
Booting and installing Kali over the network (PXE) can be useful from a single laptop install with no CDROM or USB ports, to enterprise deployments supporting preseeding of the Kali installation.

To read the full document, check our Installing Kali Linux over Network PXE (http://docs.kali.org/network-install/kali-linux-network-pxe-install) article.

If you have any issues with this procedure, please post them in this thread.

Jordan53
2013-03-24, 23:41
Tried to install booting over network (PXE) as described to the article. Couldn't find a way to avoid message:

PXE-E53: No Boot Filename Received

Is there anyone that tried this method and made it work?

Thank you.

diffusive
2014-04-30, 21:36
I've been trying (and failing) to use cobbler (http://www.cobblerd.org/) to install Kali 1.0.6 for the past few days. This is my first attempt at PXE booting debian and I had no idea that it would be so much more involved than RHEL, the system works great for booting CentOS.

So far I've gotten to the point where it boots to the installer, but then it stops at a Bad Archive Mirror message. I had imported the full iso into cobbler and replaced the /install/initrd.gz and linux files with ones provided by netboot to the article (http://docs.kali.org/network-install/kali-linux-network-pxe-install).

Through the preseed file I setup in cobbler, I've attempted to direct the install to use the cobbler http hosted image to install from but it just doesn't want to work. When the bad archive error message appears you have the option of selecting the archive to use, I try pointing it at the cobbler hosted URL for /dists/kali/ (I tried stable as well) but the installer complains that the Release file is not valid. I double checked to make sure that the URL I specify for the archive is accessible and the Release file is there.

Does anyone have any ideas what might solve the Debian archive issue for me? Does it need to point to a full Debian mirror? These hosts are not internet facing so they can't just reach out to the official repos but I can get a local mirror if that's what it takes.

A couple of other things:
1) Does anyone know the proper kernel options to provide so that this doesn't ask for a keyboard layout on install? We want this to be a completely unattended process. I've tried adding the following but it still asks me, I feel like everything I find on the internet might be outdated so these options aren't working properly for me:
keyboard-configuration/modelcode=SKIP keyboard-configuration/layout="English (US)" keyboard-configuration/variant="English (US)"

2) Examples or guidance for a preseed file to use with PXE booting kali would be awesome, I'm sure some of my frustrations are rooted in something wrong in there.

Thanks for any help!

tomtom
2014-06-25, 13:41
Read here how to Network Install Kali (PXE) with Serva
http://www.vercot.com/~serva/an/NonWindowsPXE3.html
it really works and I didn't have to touch my DHCP server.

4r7w0rk
2015-08-16, 22:06
Hello

Does someone have the netboot image for Kali 2.0 ? still the old version on the article :<

tomtom
2016-02-15, 14:56
Serva now PXE boots Kalix from v1.1.0a to v2016.1
http://www.vercot.com/~serva/an/NonWindowsPXE3.html
it uses the regular Kali distribution ISOs and a tiny additional initrd that fixes the PXE stuff. It works.

Gh0sT.sh
2016-02-26, 03:28
In a PXE environment the PXE client minimally must receive:
1. IP address
2. TFTP server IP address
3. Boot filename
This info is sometimes provided by a single DHCP server (which is PXE enabled) or
by a regular DHCP server (non PXE enabled) providing only IPs and a complementary proxyDHCP server
only providing the rest of the PXE related parameters.

In your case it looks like (despite which method you are using)
the Boot filename info is missing from the DHCP/proxyDHCP offer.

You can easily check this by running a Wireshark capture at your DHCP/proxyDHCP server
and see if the DHCPOFFER contains the Boot filename info or not. or looks like a typical DHCP/proxyDHCP miss-configuration

oconadar
2016-04-09, 15:25
Following the provided instructions provided from the link

http://docs.kali.org/installation/kali-linux-network-pxe-install

and I reach point were I type "service dnsmasq restart" in Terminal.


I am followed by the response:

"Job for dnsmasq.service failed because the control process exited with error code. See "systemctl status dnsmasq.service" and "journalctl -xe" for details."

Where are my errors? I can provide the dnsmasq.conf file and any other information needed to resolve this issue and help me continue the Network PXE install

BookerScacy
2018-02-07, 22:48
Would there be any noticeable difference running a SanDisk Ultra 8gb SD Card SDHC SDXC Class 10 40MB/s as opposed to a SanDisk ULTRA UHS-I 8GB Class 10 48MB/s MicroSDXC for Kali Linux on the Rpi2 and is 8gb sufficient?

Anonymouscookie37
2018-03-17, 05:13
When trying to download netboot.tar.gz from Kali docs, I get the error 403 Forbidden.

Hansie
2018-03-25, 13:01
The PXE install doesn't succeed :

Code added to dnsmasq.conf:

interface=eth0
dhcp-range=192.168.101.100,192.168.101.200,12h
dhcp-boot=pxelinux.0
enable-tftp
tftp-root=/tftpboot/
dhcp-option=3,192.168.101.1
dhcp-option=6,8.8.8.8,8.8.4.4

service dnsmasq restart

Error :

kali dnsmasq[1877]: TFTP directory /tftpboot/ inaccessible: No such file or directory


What's the problem?

Regards.

Hansie

Hansie
2018-03-25, 18:54
I found the solution.

In the article https://docs.kali.org/installation/kali-linux-network-pxe-install first "Download Kali PXE Netboot Images

" then


service dnsmasq restart

Hansie

Hansie
2018-03-26, 04:06
Dear Member,
Could the progress of a PXE install be indicated?

About how long takes a PXE install?

Regards.

Hansie