View Full Version : Issue at boot time (missing dtb file) with Radxa Zero image for EMMC

2022-03-06, 05:21
Hi. This is my second post so I'll try to keep the noob stuff to a minimum.

Used the community script from the Radxa Zero branch in the Kali arm tree to build an image for the Radxa Zero SoC.

The environment I used: Kali arm64 image installed on Raspberry Pi4 with 8GB RAM and booting from SSD.

Used the pre-work instructions from the "Creating a custom Kali ISO" webpage that correspond to a Kali environment.

When generating the image, I got a few warnings here and there on stage 3 about some network services that would be disabled, nothing major.

I generated images for SDcard and EMMC as both scripts were available. After 5 hours, the image was completed and compressed.

I flashed the image to an SD and tried it on the Radxa Zero.  When trying to boot, I got the following message:
Retrieving file: /usr/lib/linux-image-5.10.103//meson-g12a-radxa-zero.dtb</div><div>Failed to load '/usr/lib/linux-image-5.10.103//meson-g12a-radxa-zero.dtb'</div><div>kernel_comp_addr_r or kernel_comp_size is not provided!

I got the same result with the EMMC image. Since I have no experience in building images, my questions are:

-Is there a place I can get this dtb file from? I suspect I can probably get it from Radxa.

-Can I just "inject" the dtb file in the image by mounting it and puting the file on the right place, or do I need to put it in a specific place on the source files prior to generating the image and then modify the build script to include that file in the build process?

2022-03-21, 07:41
This is maybee the similary issue:

2022-03-30, 15:46
The script currently doesn't work, that's why it's still in Draft for the merge request. I've not had time to circle back to it just yet, but I'm hoping to this week/weekend since I now have headers on my radxa zeros and can get serial output.