View Full Version : raspberrypi install is not using whole sd card

2013-03-26, 18:15
I did a fresh install and have 16 gig sd card. But only 5 gigs are able to be used. How can I grow the partition to use all 16 gigs?
root@kali:~# df -lh
Filesystem Size Used Avail Use% Mounted on
rootfs 4.6G 4.3G 56M 99% /
/dev/root 4.6G 4.3G 56M 99% /
devtmpfs 85M 0 85M 0% /dev
tmpfs 19M 208K 19M 2% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 37M 0 37M 0% /run/shm

root@kali:~# fdisk -l

Disk /dev/mmcblk0: 16.0 GB, 16009658368 bytes
4 heads, 16 sectors/track, 488576 cylinders, total 31268864 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e166e

Device Boot Start End Blocks Id System
/dev/mmcblk0p1 1 125000 62500 c W95 FAT32 (LBA)
/dev/mmcblk0p2 125001 9765624 4820312 83 Linux

2013-03-27, 13:05
I haven't played with this myself, but these sound relevant:
http://elinux.org/RPi_raspi-config (probably the easiest)

2013-03-27, 14:48
I use a 32 gig SD card myself. This always happens.
What I usually do is just expand the partition using Gparted.

2013-03-27, 15:02
Use gparted to resize the partition

2013-03-31, 17:40
Hey guys, I've used GParted and similar tools in the past, but I'm kind of confused by the issues I'm experiencing here.

It's an ARM chromebook, to start.

it's a 64gb sdxc card.

I can boot fine into Kali, after running the 'cgpt repair x' and other cgpt commands in the instructions, but so far any changes i make to the partition setup on the sd card prevent me from booting.

gparted notes that the gpt is not using the whole disk - i can fix or ignore it. once i fix it, I can't reboot back into Kali. The partitions otherwise check out, though gparted doesn't understand the FS for the chrome kernel partitions.

Ya'll think you could help me out, or should i create my own chromebook-specific thread?

2013-03-31, 22:38
Keep it simple. Create a bootable gparted USB ISO using Linux Pen Drive or unetbootin. Boot gparted from USB, insert your Kali sd card, then refresh so gparted can see the sd card.

Once you're in the gparted GUI, partition resizing should be pretty straightforward.

By the way, I thought we were talking about the raspberry pi, not chromebook.

2013-04-03, 18:08
I'm having the same issues with both raspberry pi and chromebook images...

I'm tried resizing in in a live distro gparted with the same errors reported in this thread (and the one discussing the chromebook image.)

Perhaps someone that has done it before successfully (with these images) could post a step-by-step to help us out? I've used gparted in
the past and never encountered a problem like this...

2013-04-04, 07:51
copy pasta this:

wget http://archive.raspberrypi.org/debian/pool/main/r/raspi-config/raspi-config_20121028_all.deb
wget http://http.us.debian.org/debian/pool/main/l/lua5.1/lua5.1_5.1.5-4_armel.deb
wget http://http.us.debian.org/debian/pool/main/t/triggerhappy/triggerhappy_0.3.4-2_armel.deb
dpkg -i triggerhappy_0.3.4-2_armel.deb
dpkg -i lua5.1_5.1.5-4_armel.deb
dpkg -i raspi-config_20121028_all.deb

hit enter.

open terminal. type "raspi-config" arrow down to expand rootfs. hit enter again.
now reboot.

No need for thanks my name is Frank, if you see me at derbycon you can buy me a beer. Ha!

2013-04-04, 08:00
oops double posted

2013-04-04, 17:55
@ciphersson, @clearday

those instructions look awesome and useful and when i get a sec I'll look through relevant documentation if there is any.

I originally posted in this thread because of the shared ARM architecture, and because I have this thing against opening new threads if unnecessary. Anyway, someone else opened up a similar thread (http://forums.kali.org/showthread.php?1012-Chromebook-SD-install-only-showing-5GB-file-system) for the chromebook specifically. I'm cross-referencing the threads in the hopes that there is a simple answer that won't require modification other than perhaps cross-compiling the .deb above.

not to say that the above hasn't worked, but it takes between half an hour to an hour to DD the .img for me. I'll give it a shot this weekend.

Edit: Frank, there may be no need but thanks anyway!

Would that config allow me to create additional partitions? See my post in the thread i linked for more specific information.

2013-09-08, 15:16
Worked perfectly ... many thanks !