View Full Version : Alfa AWUS036NHA Driver on Chromebook

2013-03-27, 00:10
Trying to install my alfa card on my chromebook and receive the following error:

./scripts/driver-select ath9k_htc

make -C /lib/modules/3.4.0/build M=/usr/src/compat-drivers-3.9-rc2-2 modules
make: *** /lib/modules/3.4.0/build: No such file of directory. Stop.
make: *** [modules] Error 2

ar9271.fw is loaded in /lib/firmware/

2013-04-01, 05:57
have you tried this?

2013-06-21, 14:39
I come humbly unto you, O Collective, in search of wisdom. I'm running Kali on my Samsung Chromebook and have an ALFA AWUS036nha. LSUSB identifies it correctly but nothing makes it into 'ifconfig' except lo and mlan0. I have tried adding the firmware and supplementing the power with a dual-headed usb cable into a usb battery. Does anyone else have this problem? Or better yet, a solution? I've managed to get the image resized to take full advantage of my 32GB card so now my fight is for an injection-capable wireless adapter. Many thanks in advance.

2013-07-16, 15:28
To elaborate, when I connect the USB wireless adapter, I see the following:

[ 1290.803719] usb 1-1: new high-speed USB device number 5 using s5p-ehci
[ 1290.955646] usb 1-1: New USB device found, idVendor=0cf3, idProduct=9271
[ 1290.956169] usb 1-1: New USB Device strings: Mfr=16, Product=32, SerialNumber=48
[ 1290.956709] usb 1-1: Product: UB91C
[ 1290.956997] usb 1-1: Manufacturer: ATHEROS
[ 1290.957318] usb 1-1: SerialNumber: 12345

But never anything about the atheros driver loading.

2013-08-03, 00:31
The field idProduct=9271, is it possible that you have a newer model awus036nha (AR9271L-AL3A, instead of the older AR9271-AL1A) and the driver is not properly identifying the adapter chip and choking on the different power requirements? Source: http://wikidevi.com/wiki/ALFA_Network_AWUS036NHA

2013-10-07, 05:01
I get the same exact issue on my chromebook with the same Alfa . I had one advantage in that I have a Kali VM and I can see what drivers are missing (not that I know how to install them I am a noob in Linux). But I know enough to know what is going on. Basically the ath9k_htc driver which loads the firmware map htc_9271.fw from /lib/firmware is missing(yes htc_9271.fw is the one you need I saw it load up in dmsg). How do I know all this?

On my VM where the alfa works I was able to see the ath9k_htc driver loading the correct firmware htc_9271.fw
The entire driver is missing.. which is why we are spinning our wheels. Here is what it is supposed to look like if the driver is loaded: - at command prompt type: find . -name "*ath9k_htc"
# find . -name "*ath9k_htc"

I get zip, nada.. nothing in my chromebook on this driver. It ain't there.
So I went to the troubleshooting forums and dug this baby up: http://docs.kali.org/troubleshooting/troubleshooting-wireless-driver-issues (last bullet point of item 1. No Interface)
Which led me to this little gem .. http://wireless.kernel.org/en/users/Download/stable#Building_and_installing .. But like I say .. I am a noob and am not sure about the dependencies but it appears you have to build / install and load the ath9k_htc on the chromebooks yourself (not included with the kernel build for some reason even though the firmware map was).

I have the same problem and I don't feel proficient enough to give this a try. But if you or anyone who is more proficient than I can tell me what the script should look like or if you can resolve with this guide.. please let me know. Thanks!

2014-06-30, 00:29
I was wondering,
was this ever resolved. I am new to the forum and new to linux
I was messing around with it on my Chromebook but it will not recognize
The usb ar9721 Does not even have any activity lights Alfa-AWUS036NHA
THank you !

2014-07-09, 23:07
im having basically the same issue. when i run ifconfig absolutely nothing shows up and if i leave it plugged in for too long everything will freeze up. i do get the blue light to come on, but it just stays solid.