View Full Version : Alfa AWUSNHA not recognized

2013-03-27, 02:21
Hello all,

I'm just getting into security, and have decided to upgrade from BT 5 to Kali. I never had an issue with my wireless card in BT 5, but I can't seem to get it workin correctly in Kali. I have it installed both on a VM and on a physical drive. When I run ifconfig or iwconfig I don't see my card. However when I run lsusb I get the following:

Bus 001 Device 007: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

As you can see the wireless card is being recognized by the usb port.

When I run dmesg it looks like I'm missing either firmware or a driver. I'm not sure which it is nor do I know where to download it from or how to install it. See below:
[39290.874188] usb 1-1: Product: UB91C
[39290.874188] usb 1-1: Manufacturer: ATHEROS
[39290.874189] usb 1-1: SerialNumber: 12345
[39290.878160] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[39291.050676] usb 1-1: firmware: agent aborted loading htc_9271.fw (not found?)
[39291.050785] usb 1-1: ath9k_htc: USB layer deinitialized
[39295.412443] pcnet32 0000:02:00.0 eth0: link up

Any advice on how to solve this would be hugely appreciated.


2013-03-28, 03:14
Fixed the issue. The firmware was indeed missing. I went to the site below and downloaded the firmware. I then put the firmware in the lib/firmware folder and did a reboot. Hope this helps anyone else that may have had this issue.



2013-04-01, 05:55
thanks, Ill keep this in mind when try with my AWUS036NHA

2013-04-15, 08:58
Host : Linux Mint 14 MATE (Kernel Linux 3.5.0-22-generic)

Guest : Linux Kali / Backtrack 6 (Kernel Linux 3.7-trunk-amd64)

VBox Version : 4.2.12 r84980 (Latest Version)

Wireless Adaptor : Alfa AWUS036NHA

Chipset : Atheros AR9271 / Atheros UB91C

On the host my alfa work perfectly, but on my guest is like this :

[ 2023.183715] usb 1-1: Product: UB91C
[ 2023.183723] usb 1-1: Manufacturer: ATHEROS
[ 2023.183730] usb 1-1: SerialNumber: 12345
[ 2023.185712] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[ 2023.623632] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[ 2024.624291] ath9k_htc 1-1:1.0: ath9k_htc: Target is unresponsive
[ 2024.624344] ath9k_htc: Failed to initialize the device
[ 2024.646098] usb 1-1: ath9k_htc: USB layer deinitialized

i ve followed this but still unable http://forums.hak5.org/index.php?/topic/27344-alfa-and-wmware/page-2#entry218754
please help
lot of people like me there https://www.virtualbox.org/ticket/9511

2013-04-27, 04:21
I have this issue with virtual box aswell, my solution was to install the free vmware player

2013-04-27, 07:04
I've used virtual box or a couple of years and like it because I can leave it running plus boot up with the host machine. The networking and internet brigding are easier to use than VMware (which always crashed for me). My buddy said it has to do more with the machine which virtual hosting works better.

Try the 32 bit version of backtrack on virtual box - even if you have a 64 machine.

Edit: I would get an ALFA wifi anetena 15$ or so. The mulitdirectional uses are worth it.