View Full Version : OpenVAS Installation Error

2013-03-29, 11:05
I tried installing OpenVAS with the shortcut in the Kali Menu and I keep getting an error.

I sets up the user and loads the plugins, it then gives the following error:

ms main:WARNING:28002:2013-03-29 21h59.24 EST: sql_x: sqlite3_prepare failed:
no such table: meta

Thanks in advance.

2013-03-30, 00:08
I just ran the openvas-setup from the Kali menu (latest ISO with updates) without encountering any issues.
The error is common based on Google, I suggest you look around maybe you can find a fix.

2013-05-06, 20:25
i have this errors i have do something to remove the openvas instalation and i have this error
Step 1: Checking OpenVAS Scanner ...
OK: OpenVAS Scanner is present in version 3.4.0.
OK: OpenVAS Scanner CA Certificate is present as /var/lib/openvas/CA/cacert.pem.
OK: NVT collection in /var/lib/openvas/plugins contains 30600 NVTs.
WARNING: Signature checking of NVTs is not enabled in OpenVAS Scanner.
SUGGEST: Enable signature checking (see http://www.openvas.org/trusted-nvts.html).
Step 2: Checking OpenVAS Manager ...
OK: OpenVAS Manager is present in version 4.0.0.
OK: OpenVAS Manager client certificate is present as /var/lib/openvas/CA/clientcert.pem.
OK: OpenVAS Manager database found in /var/lib/openvas/mgr/tasks.db.
OK: Access rights for the OpenVAS Manager database are correct.
OK: OpenVAS SCAP database found in /var/lib/openvas/scap-data/scap.db.
OK: OpenVAS CERT database found in /var/lib/openvas/cert-data/cert.db.
OK: sqlite3 found, extended checks of the OpenVAS Manager installation enabled.
OK: OpenVAS Manager database is at revision 74.
OK: OpenVAS Manager expects database at revision 74.
OK: Database schema is up to date.
OK: OpenVAS Manager database contains information about 30600 NVTs.
OK: xsltproc found.
Step 3: Checking OpenVAS Administrator ...
OK: OpenVAS Administrator is present in version 1.3.0.
OK: At least one user exists.
ERROR: No admin user found. You need to create at least one admin user to log in.
FIX: Create a user using 'openvasad -c 'add_user' -n <name> -r Admin'

ERROR: Your OpenVAS-6 installation is not yet complete!

Please follow the instructions marked with FIX above and run this
script again.
when i use sudo openvasad -c add_user -n pedro -r Admin
Enter password:
ad main:MESSAGE:5908:2013-05-06 21h25.09 WEST: No rules file provided, the new user will have no restrictions.
base plcy:WARNING:5908:2013-05-06 21h25.09 WEST: error opening '/usr/etc/openvas/pwpolicy.conf': No such file or directory
ad admin:WARNING:5908:2013-05-06 21h25.09 WEST: new password for 'pedro' rejected: Password policy checking failed (internal error)
what i have to do

ad main:WARNING:5908:2013-05-06 21h25.09 WEST: Failed to create user pedro!

2013-05-07, 11:33
Generally OpenVAS will work if you run software update after first installing Kali and then the proper packages will then be installed. Otherwise "apt-get install synaptic" from the terminal then run Synaptic and check all dependencies are installed. The problem with installing OpenVAS sometimes is that if one of the mirrors is missing, out of date packages may be downloaded or some may be missing and you end up with the old problem of missing dependencies.

I'm about to install the latest version of Kali on PC (AMD64) so I will have a look and post back what I do to ensure it works. (Sorry I have to always run the the install of packages again to jog my old memory).

With ARM/ARMEL versions there are a few problems as the package names have changed a couple times recently.
I think I used "apt-get install openvas-scanner" then "apt-get install openvas-client" on armel architecture, though that was a while back so I'd have to run the install again on armel to remember if that was exactly correct. With PC architectures ensuring software update is first run before trying to install OpenVAS will ensure all packages are up to date and help avoid broken or missing dependencies.

2013-05-07, 16:46
when i use apt-get install openvas i have this errors
gsd: Depends: libopenvas5 (> = 5.0.3) but it will not be installed
E: Unable to correct problems, you have held packages (hold) spoiled.
how i repair this packets

2013-05-10, 03:46

First post here, pls be gentle...

I am unable to get OpenVAS started. I downloaded the latest .iso and installed to hard disk. I then did a Software Update before doing anything else. Followed the various setup guides and running openvas-check-setup all looks good.

openvassd - starts without issue

openvasmd - doesn't start and no message on screen. Checking the log I see 'pidfile_create': failed to open pidfile: No such file or directory.

gsad - same issue as openvasmd, and same error in the logs.

Please help! Tearing my hair out here! :)


2013-05-10, 14:14
Hi all, first post, do not shoot hard...
to install and set OpenVAS is ok to follow the previous Tutorial on backtrack website ?


Prince Authur
2013-10-30, 15:02
the same error I had encountered.did you have solve it?i need help
any help is welcome.
thx in advance

2013-10-31, 22:53
This should work... It did for me

Prince Authur
2013-11-01, 02:18
yes,it's helpful
but my openvas can't find any vulnerablilities when it scans the metasploitable target.
did your openvas work smoothly?

2013-11-02, 09:27
check this OpenVAS (http://geekyshow.blogspot.in/2013/11/how-to-setup-openvas-in-kali-linux.html)