Results 1 to 4 of 4

Thread: P4wnP1 A.L.O.A. 2022.03 - UDC driver not found when deploying USB settings. Fix found.

  1. #1
    Join Date
    2022-Oct
    Posts
    2

    Question P4wnP1 A.L.O.A. 2022.03 - UDC driver not found when deploying USB settings. Fix found.

    Hello.

    As the title says. When using the P4wnP1 A.L.O.A 2022.03 image on a pi zero w from https://www.kali.org/get-kali/#kali-arm, it doesn't let me deploy any USB configuration, instead reverting to last configuration everytime with a message saying "couldn't find a working UDC driver".

    I plugged the MicroSD card into my PC and explored the boot partition. Inside it are two files, "cmdline.txt" and "config.txt". I added "modules-load=dwc2" after "rootwait" into the former, and added "dtoverlay=dwc2" under "[all]" into the latter.

    After that I booted the pi. Got into the admin page, tried changing values and settings. Deployed. It worked.



    Will this be fixed or is it intended behavior? If not intended, the fix that worked for me is written right there.



    - CYRO

    Edit: Fixed my mistake. It's "cmdline.txt", not "commandline.txt"
    Last edited by CYRO; 2 Weeks Ago at 05:05.

  2. #2
    Join Date
    2022-Nov
    Posts
    1
    Hello, I am also facing the similar issue.

    When I try to deply the USB Gadget setting, I receive the following error message

    rpc error: code = Unknown desc = Deploying new gadget settings failed, reverted to old ones: couldn't find working



    UDC driver

    So I following your step and change the txt file below.

    In the cmdline.txt (I cannot find the commandline.txt), I change the command to;
    console=serial0,115200 console=tty1 root=PARTUUID=d0a4e52d-02 rootfstype=ext4 fsck.repair=yes modules-load=dwc2 rootwait net.ifnames=0

    In the config.txt file, I added the #dtoverlay=dwc2 according to your suggestion.

    [all]
    #dtoverlay=vc4-fkms-v3d
    #dtoverlay=dwc2



    However, I still received the same error message. Do you have any idea?

    Thank you

  3. #3
    Join Date
    2021-May
    Location
    UK
    Posts
    507
    Leave out the hash sign # at the front of your change;

    dtoverlay=dwc2

    a hash in front means it is a code comment and so will be ignored!

  4. #4
    Join Date
    2022-Oct
    Posts
    2
    Yeah, my bad, it is indeed "cmdline.txt".

    You should place modules-load=dwc2 AFTER rootwait.

    You should also remove the "#" from #dtoverlay=dwc2 in config.txt, since the "#" turns the line into a comment, which will then be ignored and thus not activated/loaded.



    Best of luck.

    - CYRO

Similar Threads

  1. Kali linux ethernet card and driver not found during installation
    By El Messia in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-02-14, 19:52
  2. Replies: 3
    Last Post: 2017-09-08, 08:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •