Results 1 to 3 of 3

Thread: Kali changing " != " to equal-sign-with-slash

  1. #1
    Join Date
    2015-Apr
    Posts
    4

    Kali changing " != " to equal-sign-with-slash

    This appears to be a Kali-specific behavior, and I'd like to ask where I can turn the behavior off.

    I am editing a Python script and when I type " != " (not equal to), those two characters are "auto-changed" to an equal sign with a diagonal slash through it.

    Where do I go to change that behavior?

    I changed terminals (qterminal and konsole); same result.

    I changed shells (zsh and bash); same result.

    I turned off all autocorrection that I can find. Still does it.

    I even pulled up my script in mousepad... it does the same thing.

    Does anyone know where this behavior is coming from? It's driving me nuts...

    Thanks.

    g

    autochange_not_equal_to.png

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    507
    That is the ligature for 'not equal to' and it happens because the terminal is using a programmers font that comes with full ligature support. From a compilation and programming point of view, the code is identical whether it uses the font ligature or != (the ligature only changes the visible appearence in terminal and code editors, it does not change the underlying characters it is comprised of).

    Anyway, to turn ligatures off usually is a setting in the fonts menus

  3. #3
    Join Date
    2022-Nov
    Posts
    1

    Lightbulb

    Quote Originally Posted by gregkedro View Post
    This appears to be a Kali-specific behavior, and I'd like to ask where I can turn the behavior off.

    I am editing a Python script and when I type " != " (not equal to), those two characters are "auto-changed" to an equal sign with a diagonal slash through it.

    Where do I go to change that behavior?

    I changed terminals (qterminal and konsole); same result.

    I changed shells (zsh and bash); same result.

    I turned off all autocorrection that I can find. Still does it.

    I even pulled up my script in mousepad... it does the same thing.

    Does anyone know where this behavior is coming from? It's driving me nuts...

    Thanks.

    g

    autochange_not_equal_to.png
    Kali Linux is a Debian-based Linux distribution aimed at advanced users and security professionals. It includes a large number of security and penetration testing tools. One of the most popular tools in Kali is the Aircrack-ng suite. Aircrack-ng allows you to crack Wi-Fi passwords and keys. By default, Aircrack-ng replaces the "!" character with a "/" character when performing password tests. This can cause problems when trying to crack passwords that use the "!" character. In this article, we will show you how to change the "!" character to an equal sign in Kali Linux account.
    Last edited by freddie123; 1 Week Ago at 09:39.

Similar Threads

  1. Back slash replaced with hash
    By skycrazy in forum NetHunter General Questions
    Replies: 1
    Last Post: 2014-10-11, 07:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •