Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: VMWare Tools in a Kali Guest

  1. #21
    Junior Member
    Join Date
    Mar 2013
    Location
    Down Under
    Posts
    8
    Ok, I know what my problem was.

    I couldn't add mirrors while installing as network wasn't enabled.

    so I added mirrors by.

    To add the sources:
    1. Use your favored text editor to open /etc/apt/sources.list

    2. Add the following two lines to your source list:
    deb http://http.kali.org/kali kali main non-free contrib
    deb-src http://http.kali.org/kali kali main non-free contrib

    3. Save and you're good to go!

    And followed every word from this
    echo cups enabled >> /usr/sbin/update-rc.d
    echo vmware-tools enabled >> /usr/sbin/update-rc.d

    apt-get install gcc make linux-headers-$(uname -r)
    ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/

    And

    Next, mount the Vmware tools ISO by clicking “Install VMware Tools” from the appropriate menu. Once the VMware Tools ISO has been attached to the virtual machine, we mount the drive and copy the VMware Tools installer to /tmp/.

    mkdir /mnt/vmware
    mount /dev/cdrom /mnt/vmware/
    cp -rf /mnt/vmware/VMwareTools* /tmp/
    Finally, change directory to /tmp/, extract the tarball and start the installer:

    cd /tmp/
    tar zxpf VMwareTools-<tools version>.tar.gz
    cd vmware-tools-distrib/
    ./vmware-tools-install
    Follow the prompts for the VMware Tools installation and you are done.
    These are quoted from the first post of the topic.

    Cheers,
    boynep

  2. #22
    Junior Member
    Join Date
    Mar 2013
    Posts
    22
    Quote Originally Posted by WOOP View Post
    2 - Have you tried to download open-vm-tools from their official repository ?

    Compiling sources is always challenging, please copy the output of your ./configure command, it gonna help us to troubleshoot your issue
    configure: error: Cannot find PAM library. Please configure without PAM (using --without-pam), or install the PAM libraries and devel package(s).


    i got this error What is PAM ?

    Quote Originally Posted by n1tr0g3n View Post
    when it asks you to type in a a valid path to the 3.7-trunk-686-pae kernel headers put "no" instead of yes and continue. That's how I installed on both my PC's using VMWare Workstation.
    Yes i did no , but after end installing i got this error :

    Unable to start services for VMware Tools

    Execution aborted.
    Last edited by sickn3ss; 2013-03-15 at 10:29 AM.

  3. #23
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    Quote Originally Posted by mhansen View Post
    When I use this command..



    I get an error saying "could not display /media/cdrom0/Vmwaretools-9.2.2-893683.tar.gz" and it says the Drive is read only.
    Unzip the file?

  4. #24
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    Hi


    Install from VMwareTools-9.2.2-893683.tar.gz

    Code:
    Distribution provided drivers for Xorg X server are used.
    
    Skipping X configuration because X drivers are not included.
    
    Creating a new initrd boot image for the kernel.
    update-initramfs: Generating /boot/initrd.img-3.7-trunk-amd64
       Starting Virtual Printing daemon:                                   done
       Checking acpi hot plug                                              done
    Starting VMware Tools services in the virtual machine:
       Switching to guest configuration:                                   done
    /etc/init.d/vmware-tools: 1088: local: ': bad variable name
       VM communication interface:                                         done
       VM communication interface socket family:                           done
    /etc/init.d/vmware-tools: 1088: local: ': bad variable name
       Blocking file system:                                              failed
    /etc/init.d/vmware-tools: 1185: local: ': bad variable name
       Guest operating system daemon:                                      done
    Unable to start services for VMware Tools
    
    Execution aborted.
    Code:
    1086  is_vmhgfs_needed() {
    1087   local min_kver=`kernel_version_integer '2' '4' '0'`
    1088   local run_kver=`get_version_integer`
    1089   if [ $min_kver -le $run_kver -a "$vmdb_answer_VMHGFS_CONFED" = 'yes' ]; then
    1090     echo yes
    1091   else
    1092     echo no
    1093   fi
    1094 }
    .
    .
    .
    1183 is_vmsync_needed() {
    1184    local min_kver=`kernel_version_integer '2' '6' '6'`
    1185    local run_kver=`get_version_integer`
    1186    if [ $min_kver -le $run_kver -a "$vmdb_answer_VMSYNC_CONFED" = 'yes' ]; then
    1187       echo yes
    1188    else
    1189       echo no
    1190    fi
    1191 }
    VMware-Tools is +- functional but the cpu is stressed abnormally high for minor operations.

    Sorry for my English.

  5. #25
    Junior Member
    Join Date
    Mar 2013
    Posts
    22
    it Seems kali have a Problem with VMware ! i install success open-vm-tools but i cant move mouse from vmware in my host Without ALT+CTRL . i cant copy and paste from Host to my VM and etc problems for VMware Tools ...

  6. #26
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    Hi everyone,

    Just trying to install VMware Tools and following the guide step by step. I echo the lines into the update-rc.d file and then do an apt-get for my linux headers. However they can't be found and I get the following error:


    Unable to locate package linux-headers-3.7-trunk-686-pae
    Couldn't find any package by regex 'linux-headers-3.7-trunk-686-pae'

    What's so unique about my kernel version that it can't find the correct headers?

  7. #27
    Junior Member
    Join Date
    Mar 2013
    Posts
    4
    Quote Originally Posted by Mehran View Post
    configure: error: Cannot find PAM library. Please configure without PAM (using --without-pam), or install the PAM libraries and devel package(s).


    i got this error What is PAM ?



    Yes i did no , but after end installing i got this error :

    Unable to start services for VMware Tools

    Execution aborted.
    This worked for me as well... I checked the repository lists and noticed they were all commented out... I also added the suggested repositories and sure enough was able to install open-vm-tools

  8. #28
    Member
    Join Date
    Apr 2013
    Posts
    32
    Quote Originally Posted by rootameen View Post
    I'm having issue with VMWare tools even after following the guide, as follows:

    1. When executing " apt-get install open-vm-tools " command, I get this error:

    "Package open-vm-tools is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source"

    2. I downloaded open-vm-tools and tried to compile them manually, I get this error:

    " checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    configure: error: Can't find include dir under /lib/modules/3.7-trunk-686-pae
    make: *** No targets specified and no makefile found. Stop.
    make: *** No rule to make target `install'. Stop."

    3. I tried to use the native tools, I'm stuck at the step:
    " apt-get install gcc make linux-headers-$(uname -r)

    I get this error

    "Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-3.7-trunk-686-pae
    E: Couldn't find any package by regex 'linux-headers-3.7-trunk-686-pae' "

    4. Even when trying to install from ./vmware-install.pl .. I'm stuck here:

    "Searching for a valid kernel header path...
    The path "" is not a valid path to the 3.7-trunk-686-pae kernel headers.
    Would you like to change it? [yes]

    Enter the path to the kernel header files for the 3.7-trunk-686-pae kernel?
    "

    Thanks in advance!

    Hi fella,

    I have posted this on the forums already so this WILL be the last time: please us the search function!!!!

    install on vmware from the iso YOURSELF forget the vm-download its full of problems (dont know why)

    Follow this guide as I have tested this soooo many times, so it is tried and tested...

    http://forums.kali.org/showthread.ph...copy-and-paste

    Kind Regards

    Dee
    Last edited by pentest09; 2013-05-11 at 04:25 PM.

  9. #29
    Junior Member
    Join Date
    Mar 2013
    Posts
    27
    Does anyone know why updating linux kernel headers cause this issue? And how do you fix it anyway?

  10. #30
    Junior Member
    Join Date
    Sep 2013
    Posts
    1
    For what it's worth, I had to install Kali with VmWare tools quickly, I have been using this setup for 2 weeks, it works well .

    https://plus.google.com/u/0/photos/1...55312745715352

    Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •