Results 1 to 6 of 6

Thread: ALFA AWUS036NHR (chipset rtl8188ru) dont show associated my adapter with AP

  1. #1
    Join Date
    2013-Mar
    Location
    Lithuania
    Posts
    2

    ALFA AWUS036NHR (chipset rtl8188ru) dont show associated my adapter with AP

    I installed kali 1.0 amd64 bit on vmware 9.0.2, and found the same problem as in BT 5R3. airodump-ng shows associated clients with AP's as non-associated. Reaver and injection works fine. I tried beni 1.2.3 which has specialy modified driver for rtl8188ru chipset and airodump-ng shows associated clients with AP's. Moreover on BT5 R3 and Kali, adapters LED doesnt blinking, is always on.
    Seems like adapter cant see "traffic" between AP's and adapters.
    Anybody have suggestions?

    Thnx

  2. #2
    Join Date
    2013-Mar
    Posts
    7
    Hello

    I have same [roblem with ,adaptor in kali and BT5R3.I can't use now.
    ...but I'm very sospicious because first time when I'v install kali on my laptop all works fine,have internet ,my conection with AP was done fast,i have can install any other software from internet ....Why now i can't conect my Alfa with AP( have 2 m between AP and my adaptor).Alaways when i have instal a new fresh copy kali was folowing all steps from the start to end.
    I have past to kali from BT5R3 and i was very satisfied first time when i see : yessssssss my adaptor work in kali and is ok now for me.... .

    Quote Originally Posted by Egidatorius View Post
    I installed kali 1.0 amd64 bit on vmware 9.0.2, and found the same problem as in BT 5R3. airodump-ng shows associated clients with AP's as non-associated. Reaver and injection works fine. I tried beni 1.2.3 which has specialy modified driver for rtl8188ru chipset and airodump-ng shows associated clients with AP's. Moreover on BT5 R3 and Kali, adapters LED doesnt blinking, is always on.
    Seems like adapter cant see "traffic" between AP's and adapters.
    Anybody have suggestions?

    Thnx

  3. #3
    Join Date
    2013-Mar
    Posts
    7
    why i see this: wlan0 Unknown rtl8192cu - [phy0]
    I don't see the chipset.... .
    why first time when i have install my kali all was fine and nowisn't ok!
    maybe after first update something wrong was hapened with my dvd or ..........
    I'm a bog noob but this one i can't undertsand.
    Thank you

    Someone can help me?!

  4. #4
    Join Date
    2013-Apr
    Posts
    1
    Quote Originally Posted by Kali44 View Post
    Hello

    I have same [roblem with ,adaptor in kali and BT5R3.I can't use now.
    ...but I'm very sospicious because first time when I'v install kali on my laptop all works fine,have internet ,my conection with AP was done fast,i have can install any other software from internet ....Why now i can't conect my Alfa with AP( have 2 m between AP and my adaptor).Alaways when i have instal a new fresh copy kali was folowing all steps from the start to end.
    I have past to kali from BT5R3 and i was very satisfied first time when i see : yessssssss my adaptor work in kali and is ok now for me.... .

    I must say, excactly the same happend to me, at first boot everything worked after that airmon-ng is empty, but i can inject packets. I truly hope that someone out there is making a fully compatible driver with monitor mode.

  5. #5
    Join Date
    2013-May
    Posts
    4
    So... I was having issues with mon mode through airmon-ng not working after a while. No APs would show up in airodump-ng or wash.
    I came to find out that I had to kill the interfering processes... Something to do with how Kali automatically logs onto networks while your tools are trying to do other things with the wifi adapter.
    Anyway, you can see what I mean in my video:
    *removed youtube vide*
    Last edited by g0tmi1k; 2013-06-04 at 08:54. Reason: Removed YouTube video

  6. #6
    Join Date
    2014-May
    Posts
    1
    I've just bought a alfa awus036nhr (chip RTL8188RU)
    I'm using Kali Linux 1.0.6 64 Bit vmware
    but when I try airmon-ng can't show me the my wireless
    Interface Chipset Driver

    I tried to install the driver from this http://www.rokland.com/mask/drivers/awus036nhr-linux.zip
    after extraction and do the command ./install.sh
    I got message error
    /root/Desktop/1/driver/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911/os_dep/linux/os_intfs.c:637:7: error: dereferencing pointer to incomplete type
    cc1: some warnings being treated as errors
    make[4]: *** [/root/Desktop/1/driver/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911/os_dep/linux/os_intfs.o] Error 1
    make[3]: *** [_module_/root/Desktop/1/driver/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.12-kali1-amd64'
    make: *** [modules] Error 2
    ##################################################
    Compile make driver error: 2
    Please check error Mesg
    ##################################################
    I don't know what's wrong please any help

Similar Threads

  1. AWUS036NHR - RTL8188RU monitor mode
    By barman in forum ARM Archive
    Replies: 0
    Last Post: 2016-12-19, 20:26
  2. Alfa AWUS036NHR - RTL8188RU
    By diego in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-05-28, 19:16
  3. Alfa awus036nhr v.2 rtl8188ru chipset drivers loading
    By Take in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-05-09, 14:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •