Results 1 to 3 of 3

Thread: big troubleshooting with apt full-upgrade

  1. #1
    Join Date
    2022-Apr
    Posts
    2

    big troubleshooting with apt full-upgrade

    Hello everyone,

    big problem with with apt full-upgrade on my kali

    Code:
    uname -a
    Linux kali 5.19.0-kali2-amd64 #1 SMP PREEMPT_DYNAMIC Debian 5.19.11-1kali2 (2022-10-10) x86_64 GNU/Linux
    Code:
    sudo apt full-upgrade
    Param?trage de linux-headers-6.0.0-kali6-amd64 (6.0.12-1kali1) ...
    /etc/kernel/header_postinst.d/dkms:
    dkms: running auto installation service for kernel 6.0.0-kali6-amd64:
    88XXau.ko:
    Running module version sanity check.
    Module version v5.6.4.2_35491.20191025 for 88XXau.ko
    exactly matches what is already found in kernel 6.0.0-kali6-amd64.
    DKMS will not replace this module.
    You may override by specifying --force.
    Error! Installation aborted.
    Error! One or more modules failed to install during autoinstall.
    Refer to previous errors for more information.
     failed!
    run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
    Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-6.0.0-kali6-amd64.postinst line 11.
    dpkg: erreur de traitement du paquet linux-headers-6.0.0-kali6-amd64 (--configure) :
     installed linux-headers-6.0.0-kali6-amd64 package post-installation script subprocess returned error exit status 1
    Param?trage de linux-image-6.0.0-kali6-amd64 (6.0.12-1kali1) ...
    /etc/kernel/postinst.d/dkms:
    dkms: running auto installation service for kernel 6.0.0-kali6-amd64:
    88XXau.ko:
    Running module version sanity check.
    Module version v5.6.4.2_35491.20191025 for 88XXau.ko
    exactly matches what is already found in kernel 6.0.0-kali6-amd64.
    DKMS will not replace this module.
    You may override by specifying --force.
    Error! Installation aborted.
    Error! One or more modules failed to install during autoinstall.
    Refer to previous errors for more information.
     failed!
    run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
    dpkg: erreur de traitement du paquet linux-image-6.0.0-kali6-amd64 (--configure) :
     installed linux-image-6.0.0-kali6-amd64 package post-installation script subprocess returned error exit status 1
    dpkg: des probl?mes de d?pendances emp?chent la configuration de linux-headers-amd64 :
     linux-headers-amd64 d?pend de linux-headers-6.0.0-kali6-amd64 (= 6.0.12-1kali1) ; cependant :
     Le paquet linux-headers-6.0.0-kali6-amd64 n'est pas encore configur?.
    
    dpkg: erreur de traitement du paquet linux-headers-amd64 (--configure) :
     probl?mes de d?pendances - laiss? non configur?
    dpkg: des probl?mes de d?pendances emp?chent la configuration de linux-image-amd64 :
     linux-image-amd64 d?pend de linux-image-6.0.0-kali6-amd64 (= 6.0.12-1kali1) ; cependant :
     Le paquet linux-image-6.0.0-kali6-amd64 n'est pas encore configur?.
    
    dpkg: erreur de traitement du paquet linux-image-amd64 (--configure) :
     probl?mes de d?pendances - laiss? non configur?
    Des erreurs ont ?t? rencontr?es pendant l'ex?cution :
     linux-headers-6.0.0-kali6-amd64
     linux-image-6.0.0-kali6-amd64
     linux-headers-amd64
     linux-image-amd64
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    and after, it is impossible to start my OS. Here is a picture:

    kali.jpg

    If someone can help me. I still can boot with the old kernel (5.19.0-kali2-amd64) but with the new one (6.0.0-kali6-amd64), it's impossible.

    Thank you.

    Theo

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    782
    Try changing system language to US english and try updating..

  3. #3
    Join Date
    2023-Mar
    Posts
    1
    I think i have the same issue on my computer after i update say this .
    dpkg: error processing package linux-headers-amd64 (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-image-amd64:
    linux-image-amd64 depends on linux-image-6.1.0-kali5-amd64 (= 6.1.12-1kali2); however:
    Package linux-image-6.1.0-kali5-amd64 is not configured yet.

    dpkg: error processing package linux-image-amd64 (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    linux-headers-6.1.0-kali5-amd64
    linux-image-6.1.0-kali5-rt-amd64
    linux-image-6.1.0-kali5-amd64
    linux-headers-amd64
    linux-image-amd64
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    any help i appreciate it ....

Similar Threads

  1. apt update && apt full-upgrade -y take an error
    By Anselmino in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2022-03-23, 10:21
  2. Font changes after full-upgrade
    By fatmanbreathing in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2022-01-03, 15:42
  3. Troubleshooting - Kali apt-get upgrade
    By OS-55002 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2020-08-18, 17:01
  4. Troubleshooting - Upgrade Metasploit 404 Not Found
    By suduma in forum TroubleShooting Archive
    Replies: 7
    Last Post: 2015-07-30, 17:00

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •