Page 2 of 8 FirstFirst 1234 ... LastLast
Results 11 to 20 of 77

Thread: Install Kali ARM on a Raspberry Pi

  1. #11
    Junior Member
    Join Date
    Mar 2013
    Posts
    8

    [Solved]

    First do ifup wlan0 (even thout it shows in iwconfig the actual interface is down on boot) add it to /etc/network/interfaces to start at boot.e
    You will also have to associate using iwconfig. Type iwconfig --help to see options.
    Next you need to run dhclient to obtain an ipv4 address if that is what your using.
    Finally you need to set your default gw.


    Quote Originally Posted by Brain View Post
    I succesfull installed the image to my SD card but I can't use my Wireless Adapter

    Code:
    root@kali:~# lsusb
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
    
    root@kali:~# iwconfig
    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
              Sensitivity:0/0
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    lo        no wireless extensions.
    eth0      no wireless extensions.
    root@kali:~# airmon-ng
    
    Interface       Chipset         Driver
    root@kali:~#
    Anyone ideas?

  2. #12
    Junior Member
    Join Date
    May 2013
    Posts
    5
    Quote Originally Posted by Brain View Post
    I succesfull installed the image to my SD card but I can't use my Wireless Adapter

    Code:
    root@kali:~# lsusb
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
    
    root@kali:~# iwconfig
    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
              Sensitivity:0/0
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    lo        no wireless extensions.
    eth0      no wireless extensions.
    root@kali:~# airmon-ng
    
    Interface       Chipset         Driver
    root@kali:~#
    Anyone ideas?
    Even though this was solved, here are some suggestions for similar problems with other wireless cards.

    This is regarding the realtek adapter, but adjust accordingly for your adapter.

    Do an lsmod to make sure the proper kernel module is loaded.

    look for 8192cu (or the appropriate module for your adapter)
    if it is not loaded, load it with modprobe 8192cu (or modprobe the appropriate module for your adapter)

    According to http://wiki.debian.org/rtl819x#External_Links the 8188 should be supported in this module. Also from my reading, it appears that this module does not need firmware. I find that peculiar... but it may be true.

    For other wireless adapters, look on the Debian wiki for the appropriate adapter.


    Sometimes it is obvious that the Linux kernel module for the wireless card is available and loaded because the wlan (or eth or ath) device shows up BUT doing an ifconfig -a and looking at the MAC address and if it is all zeros, indicates that the firmware did not load. Also reviewing the /var/log/kern.log will show what happened when the WiFi card was plugged in.

    Make sure you configure your adapter using ifconfig or the methods mentioned in the forum article mentioned below. Otherwise the adapter will not be active and attached to your AP/Router. For general wireless sniffing, you won't need to attach to any AP/Router but will need it in UP state.


    If you do need firmware for that driver and adapter combination, make sure you have the firmware for the wireless card you are using. It should be located in /lib/firmware. If it is NOT, the following may help.

    Please note, the following is a guide. Since I don't have your particular adapter, the following is just a suggestion to give you some background information. Always remember you are fully responsible for messing around with your OS and device.

    Provided your RPi has an wired ethernet connection, try one of the following:

    A) apt-get may solve your problem. You may need to add "non-free" (no quotes) to the kali line in /etc/apt/sources.list in order to install non-free Realtek firmware for apt-get to find the package.

    then do an apt-get install firmware-realtek (or the appropriate package for your adapter)

    If apt-get can't find the package, add another line to /etc/apt/sources.list, something like this:
    deb http://ftp.us.debian.org/debian squeeze main contrib non-free

    then do an apt-get install firmware-realtek (or the appropriate package for your adapter)

    B) If that doesn't work,
    try wget http://ftp.de.debian.org/debian/pool...queeze1.tar.gz
    Extract the firmware from the archive. look for firmware-nonfree/realtek/ and put it in /lib/firmware.
    cd firmware-nonfree/; mv realtek /lib/firmware

    C) If that doesn't work, try using the general explanation regarding getting and activating wireless card firmware, in this thread article http://forums.kali.org/showthread.ph...ll=1#post12206

    Note regarding the above thread article: the firmware directory located within Picuntu may not have the specific firmware you need, but it is worth a try if the you can seem to apt-get the firmware.

    D) If all else fails maybe looking at the wireless adapter vendor's site. For realtek, look here http://www.realtek.com.tw/downloads/...Downloads=true for the drivers from realtek may be helpful.

    Whichever way you install the firmware, remember to unplug and replug your wireless USB adapter so it can try and load the firmware.
    Last edited by wireless; 2013-05-19 at 03:37 PM.

  3. #13
    Junior Member
    Join Date
    Jul 2013
    Posts
    2
    Hi awesome people. I downloaded and installed the image with minimal headache, when I enter startx to launch the GUI it informs me the command can't be found, has anyone encountered this and is there a fix? Thanks for any and all help.

    Kind regards

    H

  4. #14
    Junior Member
    Join Date
    Aug 2013
    Posts
    1
    Does this come with ssh already enabled? Does anyone know how to enable ssh if I don't own a keyboard?

  5. #15
    Junior Member
    Join Date
    Aug 2013
    Posts
    8
    Last edited by g0tmi1k; 2013-09-04 at 03:33 PM.

  6. #16
    Junior Member
    Join Date
    Sep 2013
    Posts
    3

    Question wlan problem

    Hi all.
    I use the TP-Link TL-WN722N (Atheros AR9271) with RPI mod. B and I can not get my Wi-Fi adapter up.
    So, first explain what has already been tested:
    1. Power supply is normal (2.1A input) and there is no voltage drop across the control points (T1 - T2) of the board.
    2. lsusb correctly displays the connected USB device. (Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n).
    3. lsmod shows that the relevant module is loaded (ath9k_hth).
    4. ifconfig shows that i have wlan0 int and proper MAC.
    5. ifconfig wlan0 up activates the LED indicator on the dongle.

    The good news for me to come to an end.
    1. iwconfig shows that wlan0 no wireless extensions.

    Several sources I received information that my adapter does not require additional configuration. I have tried to use non-free firmware and open firmware as described in Debian Wiki, it still does not work. Perhaps I missed something, but I can not understand that. Any idea how to make it work?

  7. #17
    Junior Member
    Join Date
    Sep 2013
    Location
    AU
    Posts
    1

    Showstoppers for the RPi armel builds, present in all inc;luding 1.0.5

    [QUOTE=Mad Meow;26992]Hi all.
    I use the TP-Link TL-WN722N (Atheros AR9271) with RPI mod. B and I can not get my Wi-Fi adapter up.
    [/QUOTE


    Same issue here. Kali armel 1.0.5. Two reimages, four different WLAN nic's (rtl8187, rtl8188SU, RT3070).
    Despite an adapter appearing to be proberly detected and initialised by mac81022 and ieee80211 subsys there's something fundamentally missing from the build that's required for the full wireless stack to operate correctly.
    Couldn't see any build docos (no kernel doco files anywhere in the image) so I can't seem to progres any further.
    This cost me a day of frustration before I realised it was something fundamental to the build....
    Few other niggles (can't use serial console as a terminal, it's read-only and even then ttyAM0 seems to be unattached to kernel init msg output just after the HDMI is initt'ed (and I assume the framebuffer console get initted). Essentially you can't access thje RPi by serial console (not without reconfiguring inittab and a heap of other crap).
    Wasted ages on this till I tried a TV (HDMI/USB keyboard).. but this isn't much use to me for my application.

    ntpdate could be preinstalled for this build and pointed to an anycast or a pool.ntp.org, as well as the suggestion at install to activate the fake-hwclock module. Helps heaps with timekeeping and this debugging..
    ta

  8. #18
    Junior Member
    Join Date
    Oct 2013
    Posts
    13
    Have exactly same problem.
    New Rev 000e PI, alfa 036nha and older rtl8187 adapters refuse to work - 'wlan0 no wireless extesions'.
    Did apt-get update+upgrade, no help. Did apt-get install firmware-atheros and all others. No bad dmesg's.
    Help please =(
    Kali arm 1.0.5.

    Had to install 1.0.0 and it's working fine. Updated (apt-get dist-up/up) and adapters still work.
    Last edited by lynzoid; 2013-10-03 at 06:48 PM.

  9. #19
    Junior Member
    Join Date
    Sep 2013
    Posts
    3
    Many thanks to lynzoid. It's work and not only with TL-WN722N (Atheros).

  10. #20
    Junior Member
    Join Date
    Dec 2013
    Posts
    1
    Having a similar issue with TP-Link TL-WN725N Wireless N Nano USB-Adapter (150 Mbps, Soft AP). Can anybody help out?

    kali wifi.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •