Results 1 to 14 of 14

Thread: Installing Parallels Tools from Parallels Desktop 8 on Mac Book Pro Retina

  1. #1
    Join Date
    2013-Mar
    Posts
    2

    Installing Parallels Tools from Parallels Desktop 8 on Mac Book Pro Retina

    HI,
    I installed Kali Linux on my Retina with Parallels Desktop 8 and i need to install Parallels Tools.
    For that i had to set the installer.x86_64 permissions to read and write but now when i'm installing, i get a error saying that an error occurred when downloading required components for parallels tools installation:
    - make
    - kernel sources
    Install these components and try again

    Please help, what can ai do?


    Thanks in advance.

    Ruben Ribeiro

  2. #2
    Quote Originally Posted by nox View Post
    HI,
    I installed Kali Linux on my Retina with Parallels Desktop 8 and i need to install Parallels Tools.
    For that i had to set the installer.x86_64 permissions to read and write but now when i'm installing, i get a error saying that an error occurred when downloading required components for parallels tools installation:
    - make
    - kernel sources
    Install these components and try again

    Please help, what can ai do?


    Thanks in advance.

    Ruben Ribeiro
    Did you try what the error told you to do?

    try this within Kali before trying to install the tools:
    Code:
    apt-get update && apt-get install -y make linux-headers-$(uname -r)

  3. #3
    Join Date
    2013-Mar
    Posts
    354
    Quote Originally Posted by nox View Post
    HI,
    I installed Kali Linux on my Retina with Parallels Desktop 8 and i need to install Parallels Tools.
    For that i had to set the installer.x86_64 permissions to read and write but now when i'm installing, i get a error saying that an error occurred when downloading required components for parallels tools installation:
    - make
    - kernel sources
    Install these components and try again

    Please help, what can ai do?


    Thanks in advance.

    Ruben Ribeiro
    yes indeed, you need to install make and headers...

    Do as stated by brav0hax, those 2 files are needed to install the parallels tools...

    Luck.

  4. #4
    Join Date
    2013-Mar
    Posts
    1
    Quote Originally Posted by brav0hax View Post
    Did you try what the error told you to do?

    try this within Kali before trying to install the tools:
    Code:
    apt-get update && apt-get install -y make linux-headers-$(uname -r)
    Hello,

    I have the same problem, I tried to install linux-headers before :*

    Code:
    root@kali:~/Desktop/Parallels Tools# apt-get install -y make linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    linux-headers-3.7-trunk-686-pae is already the newest version.
    make is already the newest version.
    make set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
    But when I*tried to install parallels tools I*get this error :*

    Code:
    Parallels Tools 8.0.18354.823166 Installer started.
    2013-03-20T03:17:45-0400: Failed to setup console printk level.
    2013-03-20T03:17:52-0400: ./installer/pm.sh: line 783: [: 7-trunk-686-pae: integer expression expected
    2013-03-20T03:17:52-0400: execCmd: ./installer/pm.sh check_guest_tools 2>&1 [1]
    2013-03-20T03:19:02-0400: ./installer/pm.sh: line 783: [: 7-trunk-686-pae: integer expression expected
    Get:1 http://http.kali.org kali InRelease [22.0 kB]
    Hit http://security.kali.org kali/updates InRelease
    Get:2 http://http.kali.org kali/main Sources [7,531 kB]
    Ign http://security.kali.org kali/updates/contrib Translation-en_US
    Ign http://security.kali.org kali/updates/contrib Translation-en
    Ign http://security.kali.org kali/updates/main Translation-en_US
    Ign http://security.kali.org kali/updates/main Translation-en
    Ign http://security.kali.org kali/updates/non-free Translation-en_US
    Ign http://http.kali.org kali/contrib Translation-en_US
    Ign http://security.kali.org kali/updates/non-free Translation-en
    Ign http://http.kali.org kali/contrib Translation-en
    Ign http://http.kali.org kali/main Translation-en_US
    Ign http://http.kali.org kali/main Translation-en
    Ign http://http.kali.org kali/non-free Translation-en_US
    Ign http://http.kali.org kali/non-free Translation-en
    Hit http://security.kali.org kali/updates/main i386 Packages
    Get:3 http://http.kali.org kali/non-free Sources [116 kB]
    Hit http://security.kali.org kali/updates/contrib i386 Packages
    Hit http://http.kali.org kali/contrib Sources
    Hit http://security.kali.org kali/updates/non-free i386 Packages
    Get:4 http://http.kali.org kali/main i386 Packages [8,427 kB]
    Get:5 http://http.kali.org kali/non-free i386 Packages [114 kB]
    Hit http://http.kali.org kali/contrib i386 Packages
    Fetched 16.2 MB in 24s (657 kB/s)
    Reading package lists...
    Return code from apt-get update is 0
    WARNING: The following packages cannot be authenticated!
      linux-headers-3.7-trunk-686-pae linux-headers-3.7-trunk-common
    Authentication warning overridden.
    (Reading database ... 
    (Reading database ... 5%
    (Reading database ... 10%
    (Reading database ... 15%
    (Reading database ... 20%
    (Reading database ... 25%
    (Reading database ... 30%
    (Reading database ... 35%
    (Reading database ... 40%
    (Reading database ... 45%
    (Reading database ... 50%
    (Reading database ... 55%
    (Reading database ... 60%
    (Reading database ... 65%
    (Reading database ... 70%
    (Reading database ... 75%
    (Reading database ... 80%
    (Reading database ... 85%
    (Reading database ... 90%
    (Reading database ... 95%
    (Reading database ... 100%
    (Reading database ... 241357 files and directories currently installed.)
    Preparing to replace linux-headers-3.7-trunk-686-pae 3.7.2-0+kali5 (using .../linux-headers-3.7-trunk-686-pae_3.7.2-0+kali6_i386.deb) ...
    Unpacking replacement linux-headers-3.7-trunk-686-pae ...
    Preparing to replace linux-headers-3.7-trunk-common 3.7.2-0+kali5 (using .../linux-headers-3.7-trunk-common_3.7.2-0+kali6_i386.deb) ...
    Unpacking replacement linux-headers-3.7-trunk-common ...
    Setting up linux-headers-3.7-trunk-common (3.7.2-0+kali6) ...
    Setting up linux-headers-3.7-trunk-686-pae (3.7.2-0+kali6) ...
    WARNING: The following packages cannot be authenticated!
      dkms
    Authentication warning overridden.
    Selecting previously unselected package dkms.
    (Reading database ... 
    (Reading database ... 5%
    (Reading database ... 10%
    (Reading database ... 15%
    (Reading database ... 20%
    (Reading database ... 25%
    (Reading database ... 30%
    (Reading database ... 35%
    (Reading database ... 40%
    (Reading database ... 45%
    (Reading database ... 50%
    (Reading database ... 55%
    (Reading database ... 60%
    (Reading database ... 65%
    (Reading database ... 70%
    (Reading database ... 75%
    (Reading database ... 80%
    (Reading database ... 85%
    (Reading database ... 90%
    (Reading database ... 95%
    (Reading database ... 100%
    (Reading database ... 241357 files and directories currently installed.)
    Unpacking dkms (from .../dkms_2.2.0.3-1.2_all.deb) ...
    Processing triggers for man-db ...
    Setting up dkms (2.2.0.3-1.2) ...
    2013-03-20T03:19:02-0400: execCmd: ./installer/pm.sh download_guest_tools 2>&1 [0]
    
    Wed Mar 20 03:19:02 EDT 2013
    Start installation or upgrade of Guest Tools
    new version of parallels tools
    Installed Guest Tools were not found
    Perform installation into the /usr/lib/parallels-tools directory
    cat: /usr/lib/parallels-tools/kmods/../version: No such file or directory
    ./installer/install-kmods.sh: 36: [: Illegal number: 7-trunk-686-pae
    Start installation of prl_eth kernel module
    awk: cannot open /lib/modules/3.7-trunk-686-pae/build/include/linux/version.h (No such file or directory)
    /bin/sh: 1: [: -ge: unexpected operator
    make: Entering directory `/usr/lib/parallels-tools/kmods'
    cd prl_eth/pvmnet && make
    awk: cannot open /lib/modules/3.7-trunk-686-pae/build/include/linux/version.h (No such file or directory)
    /bin/sh: 1: [: -ge: unexpected operator
    /bin/sh: 1: [: -ge: unexpected operator
    make[1]: Entering directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    Makefile:41: *** Unsupported kernel version  in /lib/modules/3.7-trunk-686-pae/build.  Stop.
    make[1]: Leaving directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    make: *** [installme] Error 2
    make: Leaving directory `/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    Error: failed to install kernel modules
    2013-03-20T03:19:02-0400: execCmd: ./install --install [143]
    2013-03-20T03:19:02-0400: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2013-03-20T03:25:59-0400: Exiting with code 1
    2013-03-20T03:37:35-0400: 
    
    Parallels Tools 8.0.18354.823166 Installer started.
    2013-03-20T03:37:35-0400: Failed to setup console printk level.
    2013-03-20T03:37:38-0400: ./installer/pm.sh: line 783: [: 7-trunk-686-pae: integer expression expected
    2013-03-20T03:37:38-0400: execCmd: ./installer/pm.sh check_guest_tools 2>&1 [1]
    2013-03-20T03:37:57-0400: ./installer/pm.sh: line 783: [: 7-trunk-686-pae: integer expression expected
    Hit http://http.kali.org kali InRelease
    Hit http://security.kali.org kali/updates InRelease
    Hit http://http.kali.org kali/main Sources
    Hit http://security.kali.org kali/updates/main i386 Packages
    Hit http://http.kali.org kali/non-free Sources
    Hit http://security.kali.org kali/updates/contrib i386 Packages
    Hit http://http.kali.org kali/contrib Sources
    Hit http://security.kali.org kali/updates/non-free i386 Packages
    Hit http://http.kali.org kali/main i386 Packages
    Hit http://http.kali.org kali/non-free i386 Packages
    Hit http://http.kali.org kali/contrib i386 Packages
    Ign http://security.kali.org kali/updates/contrib Translation-en_US
    Ign http://security.kali.org kali/updates/contrib Translation-en
    Ign http://security.kali.org kali/updates/main Translation-en_US
    Ign http://security.kali.org kali/updates/main Translation-en
    Ign http://http.kali.org kali/contrib Translation-en_US
    Ign http://security.kali.org kali/updates/non-free Translation-en_US
    Ign http://security.kali.org kali/updates/non-free Translation-en
    Ign http://http.kali.org kali/contrib Translation-en
    Ign http://http.kali.org kali/main Translation-en_US
    Ign http://http.kali.org kali/main Translation-en
    Ign http://http.kali.org kali/non-free Translation-en_US
    Ign http://http.kali.org kali/non-free Translation-en
    Reading package lists...
    Return code from apt-get update is 0
    2013-03-20T03:37:57-0400: execCmd: ./installer/pm.sh download_guest_tools 2>&1 [0]
    
    Wed Mar 20 03:37:58 EDT 2013
    Start installation or upgrade of Guest Tools
    new version of parallels tools
    Installed Guest Tools were not found
    Perform installation into the /usr/lib/parallels-tools directory
    cat: /usr/lib/parallels-tools/kmods/../version: No such file or directory
    ./installer/install-kmods.sh: 36: [: Illegal number: 7-trunk-686-pae
    Start installation of prl_eth kernel module
    awk: cannot open /lib/modules/3.7-trunk-686-pae/build/include/linux/version.h (No such file or directory)
    /bin/sh: 1: [: -ge: unexpected operator
    make: Entering directory `/usr/lib/parallels-tools/kmods'
    cd prl_eth/pvmnet && make
    awk: cannot open /lib/modules/3.7-trunk-686-pae/build/include/linux/version.h (No such file or directory)
    /bin/sh: 1: [: -ge: unexpected operator
    /bin/sh: 1: [: -ge: unexpected operator
    make[1]: Entering directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    Makefile:41: *** Unsupported kernel version  in /lib/modules/3.7-trunk-686-pae/build.  Stop.
    make[1]: Leaving directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    make: *** [installme] Error 2
    make: Leaving directory `/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    Error: failed to install kernel modules
    2013-03-20T03:37:58-0400: execCmd: ./install --install [143]
    2013-03-20T03:37:58-0400: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2013-03-20T03:38:03-0400: Exiting with code 1
    I'm not a linux ninja, thanks in advance!

    John!

  5. #5
    Join Date
    2013-Mar
    Posts
    4
    The issue is that Parallels Tools does not support the Linux 3.7 kernel which Kali is using... Guess we are at the mercy of waiting on parallels...

    More info is available here:
    http://forums.bodhilinux.com/index.p...post__p__65986

  6. #6
    Join Date
    2013-Mar
    Posts
    4
    WOOHOO! Parallels 8 has released an update and Parallel Tools are now WORKING in Kali!

    Build 8.0.18483
    (Revision 860857; March 30, 2013)

  7. #7
    Join Date
    2013-Mar
    Posts
    1
    Quote Originally Posted by overmetal61 View Post
    WOOHOO! Parallels 8 has released an update and Parallel Tools are now WORKING in Kali!

    Build 8.0.18483
    (Revision 860857; March 30, 2013)
    Awesome! Thank you for the info!

  8. #8
    Join Date
    2013-Apr
    Posts
    12
    Quote Originally Posted by n0sup4u View Post
    Awesome! Thank you for the info!
    Thanks for the helpful information but I still can't get the Parallels tools installed. I've followed the instructions in this tread but still can't make it work. Could someone write step by step what that did to get it working. Sorry for being so dense this morning, but its been a long week

  9. #9
    Join Date
    2013-Apr
    Posts
    12
    My first post never got posted, so here is a second try.

    I've got the latest build of Parallels and have followed the suggestions in this thread, but I still get the error that it is missing make and kernel sources. Could someone put down their exact step by step process they used to get this working?

    Thank You!

  10. #10
    Join Date
    2013-Apr
    Posts
    12
    Quote Originally Posted by seag33k View Post
    My first post never got posted, so here is a second try.

    I've got the latest build of Parallels and have followed the suggestions in this thread, but I still get the error that it is missing make and kernel sources. Could someone put down their exact step by step process they used to get this working?

    Thank You!
    Figured it out. I forgot the -R when I ran chmod on my local directory of the tools. Once I did that, boom it worked. Thanks!

  11. #11
    Join Date
    2014-Jan
    Posts
    2
    Quote Originally Posted by seag33k View Post
    Figured it out. I forgot the -R when I ran chmod on my local directory of the tools. Once I did that, boom it worked. Thanks!
    I know I'm a little late to the party, but could you elaborate a bit on this?

    I have the latest build of Parallels 8 (Build 8.0.18615) and I am still unable to install Parallels Tools. I still get the following in my log after a failed installation:

    Code:
    make: Leaving directory `/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    Error: failed to install kernel modules
    2013-03-20T03:37:58-0400: execCmd: ./install --install [143]
    2013-03-20T03:37:58-0400: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2013-03-20T03:38:03-0400: Exiting with code 1
    Any ideas? I've run apt-get update and upgrade, and I've also run apt-get install -y make linux-headers-$(uname -r).

    I thought the new version of Parallels Tools was supposed to resolve the kernel compatibility problem...? Unless the latest version of Kali is up to a different unsupported kernel again?

  12. #12
    Join Date
    2013-Mar
    Posts
    354
    post the /var/log/parallels-tools-install.log file.

  13. #13
    Join Date
    2014-Jan
    Posts
    2
    Actually, the snippet from my last post had the part of the log that I thought was the most important. I double checked my kernel version and it seems that Kali is up to kernel version 3.12, while I think Parallels 8 (and maybe even 9?) still only supports linux kernel up to version 3.7. So that seems to be the reason for my problems...

    The only possible solution that I have found is to follow the instructions here to patch the installer to allow it to run on kernel 3.12: http://forum.parallels.com/showthrea...buntu-14-04%29

    But the author says it's for Parallels Tools 9 (I have 8) and I don't quite understand what the script is doing to know if it's safe to execute on my machine. Might have no choice but to give it a shot, though...

  14. #14
    Join Date
    2013-Mar
    Posts
    22
    Installing Parallels Tools to Kali Linux (Kernel v.3.12)

    Posting this here since i always seem to have a problem getting this working:

    Mount the Parallels Tools CD in the VM
    Download the patch from http://pastebin.com/8imsrmcN or here: parallels-tools-linux-3.12-prl-fs-9.0.23350.941886.patch
    Make a copy of the Parallels Tools CD, enter the directory, & patch it:
    cd /media/cdrom0
    cp -r install installer/ kmods/ tools/ version /tmp
    cd /tmp/kmods
    tar -xaf prl_mpd.tar.gz
    patch -p1 -d prl_fs < parallels-tools-linux-3.12-prl-fs-9.0.23350.941886.patch
    tar -czf prl_mod.tar.gz prl_eth prl_fs prl_fs_freeze prl_tg Makefile.kmods dkms.conf
    chmod +x install
    ./install
    Follow the GUI installer for Parallels Tools
    You should now be able to get Parallels Tools installed on kernel version 3.12.

Similar Threads

  1. Parallels Tools not installing
    By tapdanceman in forum General Archive
    Replies: 4
    Last Post: 2017-04-12, 10:42
  2. Wi-Fi scan on Parallels Desktop, virtual machine
    By redmen in forum General Archive
    Replies: 1
    Last Post: 2015-06-23, 21:15
  3. Replies: 3
    Last Post: 2013-04-06, 23:43

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •