Results 1 to 4 of 4

Thread: Not able to run Java GUI based apps

  1. #1
    Join Date
    2013-Apr
    Posts
    3

    [SOLVED] Not able to run Java GUI based apps

    Hi all!

    I have som problems running Java apps using GUI for example Burp Suite Pro and NeXpose Community installer.
    Burp Suite exits with the following message:

    Code:
    No protocol specified
    And NeXpose exits with the same type of error, clearly related to generation of the GUI:

    Code:
    Unpacking JRE ...
    Starting Installer ...
    No protocol specified
    java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11GraphicsEnvironment
    I've tried both the out of the box OpenJDK as well as Oracle's JDK 1.7.0 u17 and no luck.

    I'm running the out of the box 3.7-trunk-amd64 kernel.

    Is there anyone else having the same problem?

    Cheers!
    /C
    Last edited by circle; 2013-04-10 at 08:41.

  2. #2
    Join Date
    2013-Mar
    Posts
    12
    I had a similar problem and had to alter the command a bit to get BurpSuite Pro to work.

    java -jar /path/to/burpsuitepro.jar

  3. #3
    Join Date
    2013-Apr
    Posts
    3
    Thanks blu3,

    Well I always run things using absolute paths for security and functional reasons...occupational injury i guess

    In my case it all had to do with the Nouveau graphics driver. Anything in Java calling anything related to GUI failed due to that it could'nt locate the default display for some reason. Switching to the proprietary Nvidia driver resolved the whole thing. And this was a pure coincidence since I hade huge problems with stability using the Nouveau driver (3-5 crashes a day). Two issues squashed in one blow

    Thanks!

    Cheers!
    /C

  4. #4
    Join Date
    2013-Mar
    Posts
    12
    Quote Originally Posted by circle View Post
    Thanks blu3,

    Well I always run things using absolute paths for security and functional reasons...occupational injury i guess

    In my case it all had to do with the Nouveau graphics driver. Anything in Java calling anything related to GUI failed due to that it could'nt locate the default display for some reason. Switching to the proprietary Nvidia driver resolved the whole thing. And this was a pure coincidence since I hade huge problems with stability using the Nouveau driver (3-5 crashes a day). Two issues squashed in one blow

    Thanks!

    Cheers!
    /C
    roger that. Glad you figured it out.

Similar Threads

  1. Apps from Pwn Phone on Nethunter
    By cyb3runkn0wn in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-09-07, 08:01
  2. add additional apps to the standard kali-iso
    By john99 in forum Building Archive
    Replies: 6
    Last Post: 2014-11-24, 17:01
  3. messaging apps
    By undersc0re in forum General Archive
    Replies: 2
    Last Post: 2014-08-23, 01:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •