I have a dual boot setup on my system, running both Kali Linux and MacOS. Since I am not using Kali Linux on a virtual machine, I don't have a separate network adapter. However, when I try to use the command "airmon-ng" in Kali Linux, it informs me that the driver is "brcmfmac" and the chipset is "Broadcom Inc."
The problem I'm facing is that the command "airmon-ng start wlan0" fails to enable monitor mode on my wireless interface. I suspect that this issue is related to the driver being used. I would like to know if there is a way to change the driver for my Broadcom chipset so that I can successfully enable monitor mode.
Any guidance or suggestions on how to resolve this issue and switch to a driver that supports monitor mode would be greatly appreciated. Thank you!