Results 1 to 3 of 3

Thread: Alfa AWUS036ACH wireless card attached, but no wlan0 interface detected.

  1. #1
    Join Date
    2023-Aug
    Posts
    5

    Alfa AWUS036ACH wireless card attached, but no wlan0 interface detected.

    I am using an Alfa AWUS036ACH wireless adapter with Kali Linux in Virtualbox. My current kernel version is 6.4.0-kali3-amd64. In Virtualbox settings, I selected USB 3.0 and attached the Realtek 802.11n NIC filter.

    First I ran sudo apt update and wlan0 was present when I ran iwconfig. But after I ran sudo apt upgrade and restarted, wlan0 is no longer present as an interface, even though it's attached in the Virtualbox session.

    I also have guest additions installed. Can anyone explain why the wireless adapter is not available after upgrading? I can revert to a previous snapshot and it works again, but as soon as I upgrade and restart, it's not available anymore. I also tried restarting my host machine, FYI.


    Solved: Had to reinstall the driver and reboot, after upgrading: sudo apt install realtek-rtl88xxau-dkms
    Last edited by loby; 2023-09-02 at 17:23.

  2. #2
    Join Date
    2021-May
    Location
    UK
    Posts
    782
    dont just restart, shut down. remove adapter. restart, then plug in adapter and 'attach' it to Kali again.

  3. #3
    Join Date
    2023-Aug
    Posts
    5
    Solved, just had to run the below command to install the driver and reboot the VM.

    sudo apt install realtek-rtl88xxau-dkms

Similar Threads

  1. Replies: 1
    Last Post: 2020-03-28, 18:43
  2. Nethunter with WIFI card Alfa AWUS036ACH
    By blackboau in forum NetHunter General Questions
    Replies: 1
    Last Post: 2017-08-20, 13:56
  3. Wireless USB Interface Not Recognized - No WLAN0
    By heycubby in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2014-03-25, 15:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •