I've tried everything I can think of when I try to start yersinia -G as root. I'm not getting any error in the terminal. I get one error in the log file about Bluetooth device failed
I don't see why that would stop the GUI of yersinia working. I have ethernet adapter on the virtual machine as NAT vmnet0.
I've tried updating and upgrading kali Linux with
sudo apt update sudo apt full-upgrade -y
I've tried installing all the dependency's for yersinia and it still it wont work.

Here is my log file from yersinia hopping someone can help.

[COLOR=var(--black-800)]# yersinia v0.8.2 started in kali on Mon Sep  4 07:12:53 2023

Network Interface eth0

 eth0 iflinkname EN10MB
 eth0 iflinkdesc Ethernet
 eth0 MAC = 000c.2986.4ba9
Network Interface lo

 lo iflinkname EN10MB
 lo iflinkdesc Ethernet
 lo MAC = 0000.0000.0000
Network Interface bluetooth0
Network Interface bluetooth-monitor
pcap_open_live failed: bluetooth-monito: No such device exists (No such device exists)
Network Interface nflog
Network Interface nfqueue
Network Interface dbus-system
Network Interface dbus-session

 th_uptime thread = 4E2CD6C0
 [COLOR=var(--black-800)] gtk_gui_th = 4DACC6C0