Results 1 to 18 of 18

Thread: Screen lock not working

  1. #1
    Join Date
    2013-Mar
    Location
    MTI3LjAuMC4x
    Posts
    1

    Screen lock not working

    Hey all,
    Minor bug cropped up when installing Kali into a new VMWare machine. When locking the screen via the menu, the screen goes black as expected, but any key press or mouse move stops the screensaver and gets you back into the session without asking for a password. I've checked gnome-session-properties and screensaver and lock is ticked as expected, and calling gnome-screensaver-command -l from the command line has the same problem. Any ideas on how to get this fixed? Thanks.

  2. #2
    Join Date
    2013-Mar
    Posts
    57
    have to confim that screen lock is not working! Does other have the same issue?
    Would like to fix it

  3. #3
    Join Date
    2013-Mar
    Posts
    3

    Lock Screen WORKING

    Quote Originally Posted by tr00n3r View Post
    have to confim that screen lock is not working! Does other have the same issue?
    Would like to fix it
    You must create user account and create password on "System Setting"

    Goodluck, my screen is LOCK.
    Cyber Security Labs
    [Check Point Special Partner --- Algosec Asia Country Mgr --- SourceFire Asia Partner --- F5 Firewall & Load Balancer --- RSA 8]

  4. #4
    Join Date
    2013-Mar
    Posts
    17
    Quote Originally Posted by st3alther View Post
    You must create user account and create password on "System Setting"

    Goodluck, my screen is LOCK.
    But still isn't working for root.

  5. #5
    Join Date
    2013-Mar
    Posts
    1
    Yeah, I see the same problem. I have it actually installed on partition on my laptop, and can't seem to get it to really lock the screen for 'root'.

  6. #6
    Join Date
    2013-Mar
    Posts
    7
    Same problem on all releases I have tested: 32 bits 64 bits VMware and Raspberry.

  7. #7
    Join Date
    2013-Mar
    Location
    #offsec #kali-linux
    Posts
    8
    I've installed x64 it on my ProBook 4530s and encountering same issue. After pressing Ctrl+Alt+L it goes blank but upon pressing any key it returns back to screen.

    I've tried using a standard user and it works. However when logged in as root user it doesn't work. I've updated the bug:0000245 I reported earlier.
    Last edited by sickn3ss; 2013-04-06 at 00:45.

  8. #8
    Join Date
    2013-Mar
    Posts
    17
    It's not a bug. Locking screen as root user is blocked in the source code of "gnome-screensaver".

  9. #9
    Join Date
    2013-Apr
    Posts
    5
    Quote Originally Posted by system_crash View Post
    It's not a bug. Locking screen as root user is blocked in the source code of "gnome-screensaver".
    No matter if it's called a bug or not, there needs to be a way to lock the screen for root.

  10. #10
    Join Date
    2013-Apr
    Posts
    5
    There's a bug for it: http://bugs.kali.org/view.php?id=245

  11. #11
    Join Date
    2013-Mar
    Posts
    17
    Quote Originally Posted by aru View Post
    No matter if it's called a bug or not, there needs to be a way to lock the screen for root.
    I agree with you aru. I deleted that part of code where locking is disabled for root and it works but I'm not able to unlock my screen after that, only way to unlock it is to reboot :S

  12. #12
    Join Date
    2013-Mar
    Posts
    17
    Last edited by system_crash; 2013-04-10 at 14:26.

  13. #13
    Join Date
    2013-Apr
    Posts
    1
    You can also install xlockmore and it will lock as root I just created a menu item that runs 'xlock -mode [whatever mode you want for the screensaver] -mousemotion'

  14. #14
    Join Date
    2013-Mar
    Posts
    354
    As root, you will not be able to lock screen, why?..Due to secutity reasons.

    It is not a BUG..You need to keep in mind one thing: Debian as any other linux distro is composed by metapackages, and some of them such as Gnome is developed not by Debian team, but by gnome team.

    The gnome-screensaver will not lock screen as root due to security reasons. If you still have your doubts, well, refer here:
    https://live.gnome.org/GnomeScreensa..._in_as_root.3F

    If you want to lock screen, gnome won't let you as stated in its page. So you might need to create a new user and then you will be able to do so.

    Luck my friends.

  15. #15
    Join Date
    2013-Mar
    Location
    #offsec #kali-linux
    Posts
    8
    Bug has been resolved. Do sudo apt-get update; sudo apt-get upgrade
    http://bugs.kali.org/view.php?id=245

  16. #16
    Join Date
    2013-Mar
    Posts
    354
    Quote Originally Posted by system_crash View Post
    It's not a bug. Locking screen as root user is blocked in the source code of "gnome-screensaver".
    I totally agree with you, as I mentioned before and there is an explanation on why (I posted the gnome.org link).

  17. #17
    Join Date
    2013-Mar
    Posts
    12
    Quote Originally Posted by aru View Post
    The most recent update seems to have fixed this. My screen locks appropriately now when left idle, and prompts for a password when waking up.

  18. #18
    Join Date
    2013-Mar
    Posts
    7
    Fixed in lastest release

Similar Threads

  1. Cannot bypass lock screen
    By Paps in forum Building Archive
    Replies: 0
    Last Post: 2018-02-01, 08:58
  2. LXDE 2016.2 Lock Screen
    By oconadar in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-09-05, 21:24
  3. Upgrading to Rolling? Turn your screen lock off first!
    By AWV in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-01-29, 23:21
  4. Kali lock screen halts all terminals
    By AlienMan in forum General Archive
    Replies: 0
    Last Post: 2014-02-22, 23:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •