Results 1 to 5 of 5

Thread: Metasploit package errors please help

  1. #1
    Join Date
    2013-Apr
    Posts
    10

    Question Metasploit package errors please help

    So one day I was looking to make my system start up faster so I say postgresql and tried to remove it..... Bad idea. Turns out metasploit depends on it. So I canceled it once it said metasploit needs to be removed too. So now I get this weird error when I try to install or remove anything.

    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Setting up metasploit (4.6.1-2013052201-1kali0) ...
    insserv: Service postgresql has to be enabled to start service metasploit
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing metasploit (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    metasploit
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    I have no idea what to do from here. Any help?

  2. #2
    Join Date
    2013-Apr
    Posts
    126
    try the following commands:

    Code:
    apt-get remove metasploit && apt-get autoclean
    apt-get install metasploit
    and come back if you still have a problem.

    Good luck.

  3. #3
    Join Date
    2013-Apr
    Posts
    10
    Thanks a lot for replying but it's still there.

  4. #4
    Join Date
    2013-Mar
    Posts
    6
    Just a thought but spotted this in your error message
    " insserv: Service postgresql has to be enabled to start service metasploit "
    Have you started postgresql service
    in terminal type "service postgresql start"
    then try your install

  5. #5
    Join Date
    2013-Apr
    Posts
    126
    Quote Originally Posted by linccracker View Post
    Just a thought but spotted this in your error message
    " insserv: Service postgresql has to be enabled to start service metasploit "
    Have you started postgresql service
    in terminal type "service postgresql start"
    then try your install
    You're right.

    Sly14Cat, you will have to start the postgresql service first.

    Good luck.

Similar Threads

  1. postgresql-9.1 errors after installing a package
    By clearday in forum TroubleShooting Archive
    Replies: 22
    Last Post: 2016-03-16, 13:45
  2. Unable to locate package” errors for all software
    By aciang in forum Installing Archive
    Replies: 4
    Last Post: 2015-10-09, 13:27
  3. metasploit-concern-0.4.0 ( SEToolkit Errors )
    By Yusuf_saeed in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-04-21, 12:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •