hammerhead D821(E) 32GB
LOCK STATE - unlocked

1) Reverted to stock:
"6.0.1 (M4B30Z, Dec 2016)";
by using the "./flash_all.bat"-method

2) Enabled developer mode + USB-debugging + Allowed my computer

3) "adb reboot bootloader"

<ok so here I am wondering which TWRP-version I should flash;
TWRP 3.7.0_9 HH.R 17; https://xdaforums.com/t/recovery-uno...inued.4047653/
TWRP 3.7.0_9-0; https://dl.twrp.me/hammerhead/
or an older version of TWRP; https://dl.twrp.me/hammerhead/ >

4) Tried "twrp-3.1.1-0-hammerhead.img", "fastboot boot .\twrp-3.1.1-0-hammerhead.img"

5) Pushed (while in TWRP 3.1.1-0):
to /sdcard/Download

6) As per the official instructions;

6.1) Installed Magisk v27.0 w. no errors
6.2) Tried installing "nethunter-2024.2-hammerhead-nougat-kalifs-full.zip" which returned:
"Unpacking the installer...
Error: Unable to extract! The zip may be corrupt or your device may not have enough RAM to proceed.
Consider using a smaller installer if it is available.
Cleaning Up...
Failed to install Kali Nethunter!
Updater process ended with ERROR: 1
Error installing zip file '/sdcard/Download/nethunter-2024.2-hammerhead-nougat-kalifs-full.zip'
Updating partition details...

Any ideas?
Seen a lot of blog posts and Github gists but didn't work for me and prefer to work with official sources and files.

Best Regards - TheSwede86