Results 1 to 3 of 3

Thread: Iceweasel - upgrade - any working way to have it done?

  1. #1
    Join Date
    2013-Mar
    Posts
    31

    Iceweasel - upgrade - any working way to have it done?

    Hi,

    Is there a working way to have Iceweasel updated throught standard debian update process?

    I've tried everything I've founded over the net from adding repos to sources.list 'till to particular source compiling action but no luck though.

    I'm working right now under 18.0.1 but I know the 20.0.1 version is out already.

    Thanks.
    Last edited by Amidamaru; 2013-05-31 at 13:02.

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    You may have tried this already? Did you add the experimental source; If not edit your sources.list to include:
    Code:
    deb http://ftp.debian.org/debian experimental main
    Then the usual apt-get update, then try
    Code:
    apt-get -t experimental install iceweasel
    .
    I haven't tried this so I'm not sure it will work or not. There may be dependency problems or not.

    Or you can try to build the latest from source. As of now its 21.0-1. Though its experimental, so it may have some unknown issues. http://ftp.de.debian.org/debian/pool....debian.tar.gz

    Here is a where you can find other later builds than 18.0:
    http://packages.debian.org/source/ex...ntal/iceweasel

    I hope it helps
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Mar
    Posts
    31
    Quote Originally Posted by charonsecurity View Post
    You may have tried this already? Did you add the experimental source; If not edit your sources.list to include:
    Code:
    deb http://ftp.debian.org/debian experimental main
    Then the usual apt-get update, then try
    Code:
    apt-get -t experimental install iceweasel
    .
    I haven't tried this so I'm not sure it will work or not. There may be dependency problems or not.

    Or you can try to build the latest from source. As of now its 21.0-1. Though its experimental, so it may have some unknown issues. http://ftp.de.debian.org/debian/pool....debian.tar.gz

    Here is a where you can find other later builds than 18.0:
    http://packages.debian.org/source/ex...ntal/iceweasel

    I hope it helps

    Thanks much. I've gave it a chance but no, compiling from the source isn't an option here.

    I'll stay on the actual version until something more stable / official will got released.

Similar Threads

  1. cant't upgrade becouse gnome-core : Depends: iceweasel (>= 30)
    By lion in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-01-12, 06:17
  2. Terminal Not Working After Upgrade
    By xyodh in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-08-28, 07:39
  3. Replies: 5
    Last Post: 2014-05-13, 08:30
  4. Get Java working with Iceweasel in one step
    By jerichodotm in forum How-To Archive
    Replies: 1
    Last Post: 2014-01-19, 12:07
  5. Apt-get upgrade not working
    By Lordx19 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2013-08-22, 05:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •