Results 1 to 4 of 4

Thread: Metasploit on Kali (Linux Deploy ~ Galaxy Note-Android)

  1. #1
    Join Date
    2013-Jun
    Posts
    3

    Exclamation Metasploit on Kali (Linux Deploy ~ Galaxy Note-Android)

    I tried to install Metasploit on Kali-Android but I was getting an error and not able to proceed in installing the package.
    Already tried both 32 and 64 packages... Wish anyone could help on this... Thank you in advance.


    root@localhost:~# chmod +x metasploit-latest-linux-installer.run
    root@localhost:~# chmod +x metasploit-latest-linux-x64-installer.run
    root@localhost:~# ./metasploit-latest-linux-installer.run
    -su: ./metasploit-latest-linux-installer.run: cannot execute binary file
    root@localhost:~# ./metasploit-latest-linux-x64-installer.run
    -su: ./metasploit-latest-linux-x64-installer.run: cannot execute binary file
    root@localhost:~#

  2. #2
    Join Date
    2013-Mar
    Posts
    65
    Quote Originally Posted by raleigh View Post
    I tried to install Metasploit on Kali-Android but I was getting an error and not able to proceed in installing the package.
    Already tried both 32 and 64 packages... Wish anyone could help on this... Thank you in advance.


    root@localhost:~# chmod +x metasploit-latest-linux-installer.run
    root@localhost:~# chmod +x metasploit-latest-linux-x64-installer.run
    root@localhost:~# ./metasploit-latest-linux-installer.run
    -su: ./metasploit-latest-linux-installer.run: cannot execute binary file
    root@localhost:~# ./metasploit-latest-linux-x64-installer.run
    -su: ./metasploit-latest-linux-x64-installer.run: cannot execute binary file
    root@localhost:~#
    From what I can tell you are trying to install 32/64 metasploit on an ARM based machine. This is not possible.

    Kali comes with Metasploit in the repos...is there a reason you haven't looked there for installation?

    Best Regards,
    Eric

  3. #3
    Join Date
    2013-Jun
    Posts
    3

    Exclamation 'libreadline5:armel' is not a regular file

    Yes, I just discovered that and tried to install it thru APT but I'm getting this error with libreadline5:armel package. Hoping it can be fixed soon... Thanks

    dpkg: unrecoverable fatal error, aborting:
    files list for package 'libreadline5:armel' is not a regular file
    E: Sub-process /usr/bin/dpkg returned an error code (2)



    Code:
    login as: android
    android@192.168.0.2's password:
    Linux localhost 3.0.15-N7000DXLR5-CL968032 #3 SMP PREEMPT Fri Jul 27 18:19:04 KST 2012 armv7l
    Kali GNU/Linux 1.0 [running on Android via Linux Deploy]
    Last login: Tue Jun 25 02:34:06 2013 from localhost
    android@localhost:~$ sudo su -
    root@localhost:~# apt-get install metasploit-framework
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
      bison bundler curl git git-man less libbison-dev libcurl3 liberror-perl
      libpcap0.8 libpq5 libreadline5 m4 nmap postgresql postgresql-9.1
      postgresql-client-9.1 postgresql-client-common postgresql-common rsync
      rubygems-integration ssl-cert
    Suggested packages:
      bison-doc git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs
      git-svn git-email git-gui gitk gitweb java7-runtime-headless oidentd
      ident-server locales-all postgresql-doc-9.1 openssl-blacklist
    The following NEW packages will be installed:
      bison bundler curl git git-man less libbison-dev libcurl3 liberror-perl
      libpcap0.8 libpq5 m4 metasploit-framework nmap postgresql postgresql-9.1
      postgresql-client-9.1 postgresql-client-common postgresql-common rsync
      rubygems-integration ssl-cert
    The following packages will be upgraded:
      libreadline5
    1 upgraded, 22 newly installed, 0 to remove and 0 not upgraded.
    24 not fully installed or removed.
    Need to get 48.8 MB/49.0 MB of archives.
    After this operation, 128 MB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Get:1 http://http.kali.org/ kali/main libcurl3 armel 7.26.0-1+wheezy2 [315 kB]
    Get:2 http://http.kali.org/ kali/main libpcap0.8 armel 1.3.0-1 [136 kB]
    Get:3 http://http.kali.org/ kali/main less armel 444-4 [127 kB]
    Get:4 http://http.kali.org/ kali/main m4 armel 1.4.16-3 [246 kB]
    Get:5 http://http.kali.org/ kali/main libbison-dev armel 1:2.5.dfsg-2.1 [289 kB]
    Get:6 http://http.kali.org/ kali/main bison armel 1:2.5.dfsg-2.1 [668 kB]
    Get:7 http://http.kali.org/ kali/main bundler all 1.1.4-6 [146 kB]
    Get:8 http://http.kali.org/ kali/main curl armel 7.26.0-1+wheezy2 [268 kB]
    Get:9 http://http.kali.org/ kali/main liberror-perl all 0.17-1 [23.6 kB]
    Get:10 http://http.kali.org/ kali/main git-man all 1:1.7.10.4-1+wheezy1 [1,074 kB]
    Get:11 http://http.kali.org/ kali/main git armel 1:1.7.10.4-1+wheezy1 [5,880 kB]
    Get:12 http://http.kali.org/ kali/main git armel 1:1.7.10.4-1+wheezy1 [5,880 kB]
    Get:13 http://http.kali.org/ kali/main libpq5 armel 9.1.9-1 [512 kB]
    Get:14 http://http.kali.org/ kali/main postgresql-client-common all 134wheezy3 [62.8 kB]
    Get:15 http://http.kali.org/ kali/main postgresql-client-9.1 armel 9.1.9-1 [1,331 kB]
    Get:16 http://http.kali.org/ kali/main ssl-cert all 1.0.32 [19.5 kB]
    Get:17 http://http.kali.org/ kali/main postgresql-common all 134wheezy3 [138 kB]
    Get:18 http://http.kali.org/ kali/main postgresql-9.1 armel 9.1.9-1 [3,359 kB]
    Get:19 http://http.kali.org/ kali/main postgresql all 9.1+134wheezy3 [42.4 kB]
    Get:20 http://http.kali.org/ kali/main rsync armel 3.0.9-4 [356 kB]
    Get:21 http://http.kali.org/ kali/main rubygems-integration all 1.1 [4,782 B]
    Get:22 http://http.kali.org/ kali/main nmap armel 6.25-1kali3 [4,960 kB]
    Get:23 http://http.kali.org/ kali/main metasploit-framework armel 4.6.2-2013061901-1kali0 [28.9 MB]
    Fetched 46.9 MB in 1h 28min 59s (8,782 B/s)
    Preconfiguring packages ...
    dpkg: unrecoverable fatal error, aborting:
     files list for package 'libreadline5:armel' is not a regular file
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    I tried again but still got the same error:


    Code:
    root@localhost:~# apt-get install metasploit-framework
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
      bison bundler curl git git-man less libbison-dev libcurl3 liberror-perl
      libpcap0.8 libpq5 libreadline5 m4 nmap postgresql postgresql-9.1
      postgresql-client-9.1 postgresql-client-common postgresql-common rsync
      rubygems-integration ssl-cert
    Suggested packages:
      bison-doc git-daemon-run git-daemon-sysvinit git-doc git-el git-arch git-cvs
      git-svn git-email git-gui gitk gitweb java7-runtime-headless oidentd
      ident-server locales-all postgresql-doc-9.1 openssl-blacklist
    The following NEW packages will be installed:
      bison bundler curl git git-man less libbison-dev libcurl3 liberror-perl
      libpcap0.8 libpq5 m4 metasploit-framework nmap postgresql postgresql-9.1
      postgresql-client-9.1 postgresql-client-common postgresql-common rsync
      rubygems-integration ssl-cert
    The following packages will be upgraded:
      libreadline5
    1 upgraded, 22 newly installed, 0 to remove and 0 not upgraded.
    24 not fully installed or removed.
    Need to get 0 B/49.0 MB of archives.
    After this operation, 128 MB of additional disk space will be used.
    Do you want to continue [Y/n]?
    Preconfiguring packages ...
    dpkg: unrecoverable fatal error, aborting:
     files list for package 'libreadline5:armel' is not a regular file
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    root@localhost:~#
    Any input would be greatly appreciated. Thank you.

  4. #4
    Join Date
    2014-Oct
    Posts
    1
    You can use linux complete installer apk. It's easy and fast and there is no neee to install programs, but you have to download kali image file for android(just google it).(remember if your memory is fat32 you can't have a file larger than 4GB in it, so download carefully)
    If linux complete installer didn't work, try linux deploy with same image file, it's a little BORING!

Similar Threads

  1. Install on Galaxy Tab 4 7" using Linux Deploy
    By Gnobodyuknow in forum Installing Archive
    Replies: 0
    Last Post: 2015-06-03, 10:39
  2. Replies: 2
    Last Post: 2014-12-08, 21:54
  3. Replies: 3
    Last Post: 2014-06-02, 09:53
  4. kali linux 1.06 galaxy note 10.1. no ETA yet?
    By Halcyon in forum ARM Archive
    Replies: 1
    Last Post: 2014-01-19, 17:33
  5. Replies: 0
    Last Post: 2013-04-09, 22:34

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •