Results 1 to 9 of 9

Thread: DNS problem: ping works, nslookup works, wget and browser do not.

  1. #1
    Join Date
    2013-May
    Posts
    16

    DNS problem: ping works, nslookup works, wget and browser do not.

    I've checked my resolv.conf file, and it matches the other working computers on the LAN. The only thing I can think of is that curl, metasploit, and a couple other things got updated the other day, and now I can't load pages by name. For instance, I get
    Could not resolve 'http.kali.org'
    But I can load them by IP address. Someone please tell me what the **** is going on.

  2. #2
    Join Date
    2013-May
    Posts
    16
    This might shed some light on the issue,
    $ sudo dhclient wlan0
    Reloading /etc/samba/smb.conf: smbd only.
    RTNETLINK answers: File exists

  3. #3
    Join Date
    2013-May
    Posts
    16
    Does anybody know how to troubleshoot this problem?

  4. #4
    Join Date
    2013-May
    Posts
    16
    How would I check for "new services"? I didn't activate anything new, if that's what you're asking. I cannot apt-get anything with this problem. The problem only occurred the day after I performed the updates.

  5. #5
    Join Date
    2013-May
    Posts
    16
    The problem has resolved itself somehow after a restart. I had installed Wicd, and I think there may have been a conflict between Wicd and the preexisting network manager. Now Wicd handles everything.

  6. #6
    Join Date
    2013-May
    Posts
    16
    Scratch that. The problem surfaces when I'm on an AT&T nameserver. Are they intentionally blocking access for Kali machines?

  7. #7
    Join Date
    2013-May
    Posts
    16
    Ok, see http://www.dslreports.com/faq/5975. I've tried several different MTUs, but I'll test it more thoroughly later and report back. If someone is aware of a script that auto-detects the optimal MTU on a network, that would be pretty handy.

  8. #8
    Join Date
    2013-Mar
    Posts
    269
    Try manually setting your DNS in your internet connection settings to the Google DNS. 8.8.8.8, and 8.8.4.4 See if that helps.
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  9. #9
    Join Date
    2013-May
    Posts
    16
    Quote Originally Posted by charonsecurity View Post
    Try manually setting your DNS in your internet connection settings to the Google DNS. 8.8.8.8, and 8.8.4.4 See if that helps.
    You're saying I can set these as my nameservers in the resolv.conf file? Is there a special way to prevent the resolv.conf file from getting changed each time I connect to a different network? I've noticed that until my resolv.conf file gets updated on the AT&T network, my internet works with no problem. Thanks, by the way.

    Following the advice of the article in post #8, I've found that an MTU below 1400 works. Contrary to the article, I am in the Southwest and apparently AT&T sucks no matter where you go in the country.

Similar Threads

  1. Replies: 1
    Last Post: 2015-05-08, 02:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •