Results 1 to 4 of 4

Thread: XRDP question

  1. #1
    Join Date
    2013-Jul
    Posts
    1

    XRDP question

    We have Kali residing in a data center.

    I grabbed a copy of xrdp (xrdp_0.5.0-2_i386.deb) and installed it on the machine remotely. I made a .xsession file with one line in it: gnome-session and connected. Everything worked correctly except that when I hit the Up|Down arrows it doesn't cycle through the CLI history. Instead it maximizes and minimizes the window I'm in.

    Any idea on how to fix that? I'm not sure I can retrain my brain to not use the up|down arrows.

    If it matters, I'm connecting from Win 8 enterprise using RDP.

    Thanks.

  2. #2
    Same here. SSH works for most CLI stuff... I hate VNC. Maybe someone can toss some other ideas around? Setting up a VPN and then using VNC I guess...

  3. #3
    Join Date
    2013-Feb
    Posts
    225
    This seems like a common problem with xrdp. Check this post for some examples:
    http://c-nergy.be/blog/?p=3858

  4. #4
    Join Date
    2014-Jan
    Posts
    1
    I had this issue and tried the following the guide above, however, it didn't fix the issue. Which I could have screwed something up along the way. However, I found that if you remove the key bind (i.e. "Super+Up") for the "Toggle fullscreen mode" and "Restore window" setting in the keyboard shortcuts for Windows fixes the issue. This will have to be done for each user through.

Similar Threads

  1. How to set up xrdp on the AWS Kali image
    By schroeder in forum How-To Archive
    Replies: 4
    Last Post: 2018-03-27, 10:59
  2. xrdp stopped working
    By alg in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-01-19, 22:15
  3. xrdp crashes when opening a program
    By swoop124 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2014-04-25, 10:00
  4. XRDP + OpenVAS problem
    By BigSam in forum General Archive
    Replies: 1
    Last Post: 2014-04-23, 19:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •