Page 1 of 14 12311 ... LastLast
Results 1 to 10 of 138

Thread: Troubleshooting Wireless Drivers

  1. #1
    Administrator
    Join Date
    Feb 2013
    Posts
    33

    Troubleshooting Wireless Drivers

    Troubleshooting Wireless driver issues in Linux can be a frustrating job if you don’t know what to look for.

    To read the full document, check our Troubleshooting Wireless Drivers article.


    If you have any issues with this procedure, please post them in this thread.

  2. #2
    I'm trying to use an Alfa awus036H through mapped as a usb device in VirtualBox; it shows up in lsusb but not as an interface dmesg | tail shows the following error which I haven't been able to figure out:

    [ 3522.900488] usb 1-2: new full-speed USB device number 6 using ohci_hcd
    [ 3533.121268] usb 1-2: string descriptor 0 read error: -110
    [ 3533.121276] usb 1-2: New USB device found, idVendor=0bda, idProduct=8187
    [ 3533.121277] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3538.129947] usb 1-2: can't set config #1, error -110

  3. #3
    Member
    Join Date
    Mar 2013
    Location
    In AnonWorld
    Posts
    38
    hi
    when i downloaded and installed it after reboot it kali hanged :x now i have reinstalled it.what do u recommend for D-link dwa 160 (b2) thanks for ur support :P

  4. #4
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    i have a Broadcom bcm4311 b/g wireless card and i cant get the firmware to work with kali

    plix help!

    ive tryed apt-get install frimware-b43-installer

    removed the module then readded it and when i readd it i get blank screen!

  5. #5
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    Quote Originally Posted by bolexxx View Post
    Troubleshooting Wireless driver issues in Linux can be a frustrating job if you don’t know what to look for.

    To read the full document, check our Troubleshooting Wireless Drivers article.


    If you have any issues with this procedure, please post them in this thread.

    1. i think on that link, cannot describe how to activate device wireless Alfa AWUS036NH
    2. lspci or lsusb the result is detected alfa device but how to step by step to work "Mode monitor and Injection mode"

    thank you for the step by step command

    Rgds,
    HR
    Cyber Security Labs
    [Check Point Special Partner --- Algosec Asia Country Mgr --- SourceFire Asia Partner --- F5 Firewall & Load Balancer --- RSA 8]

  6. #6
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    i have dell inspiron 1564 with dell mini wireless card 1397 but it doesnt work and i have also kasper card but after viewing the networks and connect the connection reset and no pages are loading any help please with any one of them and thanks in advance

  7. #7
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    Quote Originally Posted by quiteDEADlee View Post
    I'm trying to use an Alfa awus036H through mapped as a usb device in VirtualBox; it shows up in lsusb but not as an interface dmesg | tail shows the following error which I haven't been able to figure out:

    [ 3522.900488] usb 1-2: new full-speed USB device number 6 using ohci_hcd
    [ 3533.121268] usb 1-2: string descriptor 0 read error: -110
    [ 3533.121276] usb 1-2: New USB device found, idVendor=0bda, idProduct=8187
    [ 3533.121277] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 3538.129947] usb 1-2: can't set config #1, error -110
    I'm experiencing the same problem.

  8. #8
    Junior Member
    Join Date
    Mar 2013
    Posts
    1
    I use the RTL8111/8168B network card nd cannot get it to work. I have tried many different things.

  9. #9
    Junior Member
    Join Date
    Apr 2013
    Posts
    1
    Hi all, sorry my english write in google translate... I have a problem usb wifi card asus n13 strangely behaves displays network one 5-10 seconds after turning on the computer and don't obtaining ip - address, hide all wifi access point. I don't known that do but linux backtrack 5 r3 wifi good work...

    prompting command line:

    iwlist wlan0 scan
    wlan0 No scan results

  10. #10
    Junior Member
    Join Date
    Apr 2013
    Location
    Philadelphia, PA, USA
    Posts
    4
    kali 1.0.1 all updates and upgrades installed. 3.7-trunk-amd64 kernel on an hp elitebook 8540p. centrino 4965 works great with iwlwifi out of the box, but trying to install a linksys wusb54g v4 (ralink rt2570 chip) not working. here is the output when we plug in or reload the kernel module:

    Code:
    root@jc-elite:~# modprobe -r rt2500usb
    root@jc-elite:~# modprobe rt2500usb
    root@jc-elite:~# dmesg | tail
    [ 3736.978336]  [<ffffffffa06a3000>] ? 0xffffffffa06a2fff
    [ 3736.978342]  [<ffffffff810020b6>] ? do_one_initcall+0x75/0x12b
    [ 3736.978348]  [<ffffffffa06a3000>] ? 0xffffffffa06a2fff
    [ 3736.978355]  [<ffffffffa06a3000>] ? 0xffffffffa06a2fff
    [ 3736.978361]  [<ffffffff81083c4f>] ? sys_init_module+0x105/0x251
    [ 3736.978368]  [<ffffffff8137d8a9>] ? system_call_fastpath+0x16/0x1b
    [ 3736.978371] ---[ end trace 8366e3e874e1db46 ]---
    [ 3736.978375] phy4 -> rt2x00lib_probe_dev: Error - Failed to initialize hw.
    [ 3736.978393] rt2500usb: probe of 1-2:1.0 failed with error -22
    [ 3736.978426] usbcore: registered new interface driver rt2500usb
    seems to be like the problem mentioned in this post: https://groups.google.com/forum/?fro...el/dthMMtBVhV4

    then tried downloading and installing a new driver for the rt2570 and it would not compile:

    Code:
    root@jc-elite:~/rt2570-k2wrlz-1.6.4/Module# ls
    assoc.c     md5.c          rt2570.h        rtmp_def.h    rtusb.h       sha1.h
    auth.c      md5.h          rt2570sw.h      rtmp_tkip.c   rtusb_info.c  sync.c
    auth_rsp.c  mlme.c         rt2x00debug.c   rtmp_type.h   rtusb_init.c  wpa.c
    connect.c   mlme.h         rt2x00debug.h   rtmp_wep.c    rtusb_io.c    wpa.h
    Makefile    modules.order  rt_config.h     rtusb_bulk.c  rtusb_main.c
    Makefile~   oid.h          rtmp_ckipmic.h  rtusb_data.c  sanity.c
    root@jc-elite:~/rt2570-k2wrlz-1.6.4/Module# make
    make[1]: Entering directory `/usr/src/linux-headers-3.7-trunk-amd64'
      Building modules, stage 2.
      MODPOST 0 modules
    make[1]: Leaving directory `/usr/src/linux-headers-3.7-trunk-amd64'
    rt2570.ko failed to build!
    make: *** [module] Error 1
    root@jc-elite:~/rt2570-k2wrlz-1.6.4/Module#
    yes, i have the linux-headers installed for this kernel. unsure why i can't compile this. so i tried getting compat-wireless and compiling, and got this:
    Code:
      CC [M]  /root/compat-wireless-3.6.8-1/drivers/bluetooth/hci_ath.o
    /root/compat-wireless-3.6.8-1/drivers/bluetooth/hci_ath.c: In function ‘ath_wakeup_ar3k’:
    /root/compat-wireless-3.6.8-1/drivers/bluetooth/hci_ath.c:61:2: error: incompatible type for argument 2 of ‘memcpy’
    In file included from /usr/src/linux-headers-3.7-trunk-common/arch/x86/include/asm/string.h:4:0,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/string.h:17,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/dynamic_debug.h:100,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/kernel.h:14,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/plist.h:78,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/pm_qos.h:7,
                     from /root/compat-wireless-3.6.8-1/include/linux/pm_qos.h:7,
                     from /usr/src/linux-headers-3.7-trunk-common/include/linux/netdevice.h:28,
                     from /root/compat-wireless-3.6.8-1/include/linux/compat-2.6.29.h:5,
                     from /root/compat-wireless-3.6.8-1/include/linux/compat-2.6.h:49,
                     from <command-line>:0:
    /usr/src/linux-headers-3.7-trunk-common/arch/x86/include/asm/string_64.h:32:14: note: expected ‘const void *’ but argument is of type ‘struct ktermios’
    make[5]: *** [/root/compat-wireless-3.6.8-1/drivers/bluetooth/hci_ath.o] Error 1
    make[4]: *** [/root/compat-wireless-3.6.8-1/drivers/bluetooth] Error 2
    make[3]: *** [_module_/root/compat-wireless-3.6.8-1] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.7-trunk-amd64'
    make: *** [modules] Error 2
    root@jc-elite:~/compat-wireless-3.6.8-1#
    So i am basically stuck, and although I could go buy another usb wlan dongle, I want to make this work because it works fine in backtrack5r3(kde64) as well as bugtraq2blackwidow(ubuntu 3.26 based), and I thought it would be a good exercise that would help people if solved in public forum.

    Thanks guys for any light you can shed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •